summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-03 17:24:39 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-03 17:24:39 +0000
commit722c5cfbe9073c38cb6e8b1dd3adcca59ce3babe (patch)
tree017bcf63b008a3a064749b04f3bc02e3d738f395 /x11-libs/qt-test
parentMarking gnome-mag-0.15.9 ppc64 for bug 281427 (diff)
downloadgentoo-2-722c5cfbe9073c38cb6e8b1dd3adcca59ce3babe.tar.gz
gentoo-2-722c5cfbe9073c38cb6e8b1dd3adcca59ce3babe.tar.bz2
gentoo-2-722c5cfbe9073c38cb6e8b1dd3adcca59ce3babe.zip
added qt-4.6-nolibx11.diff patch
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-test')
-rw-r--r--x11-libs/qt-test/ChangeLog6
-rw-r--r--x11-libs/qt-test/files/qt-4.6-nolibx11.diff18
-rw-r--r--x11-libs/qt-test/qt-test-4.6.0.ebuild6
3 files changed, 28 insertions, 2 deletions
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index aa61cfae2809..d417da5b2db3 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.54 2009/12/01 18:07:00 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.55 2009/12/03 17:24:38 wired Exp $
+
+ 03 Dec 2009; Alex Alexander <wired@gentoo.org>
+ +files/qt-4.6-nolibx11.diff, qt-test-4.6.0.ebuild:
+ added qt-4.6-nolibx11.diff patch
01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
-qt-test-4.6.0_rc1.ebuild:
diff --git a/x11-libs/qt-test/files/qt-4.6-nolibx11.diff b/x11-libs/qt-test/files/qt-4.6-nolibx11.diff
new file mode 100644
index 000000000000..d3c1d1f75121
--- /dev/null
+++ b/x11-libs/qt-test/files/qt-4.6-nolibx11.diff
@@ -0,0 +1,18 @@
+--- configure.old 2009-12-03 18:52:58.061117684 +0200
++++ configure 2009-12-03 18:53:09.065116496 +0200
+@@ -5010,15 +5010,6 @@
+ X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
+ fi
+
+- # Check we actually have X11 :-)
+- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
+- if [ $? != "0" ]; then
+- echo "Basic XLib functionality test failed!"
+- echo " You might need to modify the include and library search paths by editing"
+- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
+- exit 1
+- fi
+-
+ # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
+ if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
+ if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-test/qt-test-4.6.0.ebuild b/x11-libs/qt-test/qt-test-4.6.0.ebuild
index eaf10c2e06b7..a226dbb579f1 100644
--- a/x11-libs/qt-test/qt-test-4.6.0.ebuild
+++ b/x11-libs/qt-test/qt-test-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.6.0.ebuild,v 1.1 2009/12/01 15:01:57 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.6.0.ebuild,v 1.2 2009/12/03 17:24:38 wired Exp $
EAPI="2"
inherit qt4-build
@@ -19,6 +19,10 @@ include/QtTest/
include/QtCore/
src/corelib/"
+PATCHES=(
+ "${FILESDIR}/qt-4.6-nolibx11.diff"
+)
+
src_configure() {
myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl