summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-02-15 15:08:02 +0000
committerDror Levin <spatz@gentoo.org>2010-02-15 15:08:02 +0000
commit97930eeb72691871a61005e986dffac23a286399 (patch)
tree5c11f28a1ca4975850d6951984758d22c494a8d0 /x11-libs/qt/qt-4.6.2.ebuild
parentVersion bump thanks to John Brendler (bug #304841). (diff)
downloadgentoo-2-97930eeb72691871a61005e986dffac23a286399.tar.gz
gentoo-2-97930eeb72691871a61005e986dffac23a286399.tar.bz2
gentoo-2-97930eeb72691871a61005e986dffac23a286399.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt/qt-4.6.2.ebuild')
-rw-r--r--x11-libs/qt/qt-4.6.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/qt/qt-4.6.2.ebuild b/x11-libs/qt/qt-4.6.2.ebuild
new file mode 100644
index 000000000000..dda45d156254
--- /dev/null
+++ b/x11-libs/qt/qt-4.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.6.2.ebuild,v 1.1 2010/02/15 15:08:02 spatz Exp $
+
+EAPI=2
+DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework"
+HOMEPAGE="http://qt.nokia.com/"
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus kde opengl qt3support"
+
+DEPEND=""
+RDEPEND="~x11-libs/qt-core-${PV}
+ ~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-svg-${PV}
+ ~x11-libs/qt-sql-${PV}
+ ~x11-libs/qt-script-${PV}
+ ~x11-libs/qt-xmlpatterns-${PV}
+ dbus? ( ~x11-libs/qt-dbus-${PV} )
+ opengl? ( ~x11-libs/qt-opengl-${PV} )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV} media-sound/phonon ) )
+ kde? ( media-sound/phonon )
+ qt3support? ( ~x11-libs/qt-qt3support-${PV} )
+ ~x11-libs/qt-webkit-${PV}
+ ~x11-libs/qt-test-${PV}
+ ~x11-libs/qt-multimedia-${PV}
+ ~x11-libs/qt-assistant-${PV}"
+
+pkg_postinst() {
+ echo
+ elog "Please note that this meta package is only provided for convenience."
+ elog "No packages should depend directly on this meta package, but on the"
+ elog "specific split Qt packages needed. This ebuild will be removed in"
+ elog "future versions. Users that want all Qt components installed are"
+ elog "advised to use the set currently available in qting-edge overlay."
+ echo
+}