summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
commitbc47766e01dc5f8f9db197c198f9c4a5be5ba070 (patch)
treee22951a3c8bf89bb39abad557cf4574f6e3dcd6d /x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
parentperl testing on ppc; added positive test results (diff)
downloadgentoo-2-bc47766e01dc5f8f9db197c198f9c4a5be5ba070.tar.gz
gentoo-2-bc47766e01dc5f8f9db197c198f9c4a5be5ba070.tar.bz2
gentoo-2-bc47766e01dc5f8f9db197c198f9c4a5be5ba070.zip
modernised
Diffstat (limited to 'x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild b/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
index f01c52c34e87..bc977dd92daa 100644
--- a/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
+++ b/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild,v 1.4 2002/08/01 11:59:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.15-r3.ebuild,v 1.5 2002/08/05 10:02:51 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GTK/GDK bindings for the librep Lisp environment"
SRC_URI="mirror://sourceforge/rep-gtk/${P}.tar.gz"
HOMEPAGE="http://rep-gtk.sourceforge.net/"
-SLOT="gtk-1.2"
+
+SLOT="1.2"
LICENSE="GPL-2"
KEYWORDS="x86"
DEPEND="=x11-libs/gtk+-1.2*
>=dev-libs/librep-0.13.4
gnome? ( >=gnome-base/libglade-0.17-r1
- >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )"
RDEPEND="=x11-libs/gtk+-1.2*
gnome? ( >=gnome-base/libglade-0.17-r1
- >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )"
src_compile() {
local myconf=""
@@ -32,18 +33,14 @@ src_compile() {
--without-gnome-canvas-pixbuf"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- ${myconf} || die
-
+ econf ${myconf} || die
make || die
}
-src_install() {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS BUGS COPYING ChangeLog README* TODO
docinto examples
dodoc examples/*
}
-