summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-23 01:26:24 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-23 01:26:24 +0000
commitf1f76eafb06853193757f3db15212d108cf89fba (patch)
tree180afbf524616257f0311aa9878f879959a7bdfb /x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild
parentRESTRICT=maketest -> RESTRICT=test (diff)
downloadgentoo-2-f1f76eafb06853193757f3db15212d108cf89fba.tar.gz
gentoo-2-f1f76eafb06853193757f3db15212d108cf89fba.tar.bz2
gentoo-2-f1f76eafb06853193757f3db15212d108cf89fba.zip
Use tc-getCC to solve libtool tag problems #70514
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild b/x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild
new file mode 100644
index 000000000000..ace296d17290
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18-r2.ebuild,v 1.1 2005/06/23 01:26:24 agriffis Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="gnome"
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+SLOT="gtk-2.0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc
+ >=dev-util/pkgconfig-0.12.0
+ >=x11-libs/gtk+-2.0.3
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libgnomecanvas-2.0.0
+ >=gnome-base/libglade-2.0.0
+ >=sys-devel/automake-1.6.1-r5
+ >=dev-libs/librep-0.13"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # Fix for bug 45646 to sync up rep-gtk headers with gtk+
+ if has_version '>=x11-libs/gtk+-2.4'; then
+ epatch ${FILESDIR}/rep-gtk-0.18-gtk24.patch
+ fi
+
+ # Remove reference to gtk internal functions. These functions are no
+ # longer available in recent versions of gtk, and sawfish doesn't use
+ # them anyway. Bug 48439, patch from fn_x
+ epatch ${FILESDIR}/rep-gtk-0.18-gtk26.patch
+}
+
+src_compile() {
+ CC=$(tc-getCC) econf \
+ --with-libglade \
+ --with-gdk-pixbuf \
+ $(use_with gnome) || die
+ emake host_type=${CHOST} || die
+}
+
+src_install() {
+ make install \
+ host_type=${CHOST} \
+ installdir=${D}/usr/lib/rep/${CHOST} || die
+
+ cd ${S}
+ dodoc AUTHORS BUGS COPYING ChangeLog HACKING \
+ NEWS README* TODO
+}
+