summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-12 14:04:55 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-12 14:04:55 +0000
commit0a7b052152c5fb79bf082c8122e56bd8318e0f97 (patch)
treecaa3b29ea5e90cbb1af63d8785d6696bf0cf2a24 /x11-libs/rep-gtk
parentQA: avoid creating empty directory; the udev rules are not installed in /udev... (diff)
downloadgentoo-2-0a7b052152c5fb79bf082c8122e56bd8318e0f97.tar.gz
gentoo-2-0a7b052152c5fb79bf082c8122e56bd8318e0f97.tar.bz2
gentoo-2-0a7b052152c5fb79bf082c8122e56bd8318e0f97.zip
Version bump, drop .la files.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/rep-gtk')
-rw-r--r--x11-libs/rep-gtk/ChangeLog7
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index 418565ffc85f..6a8e75ad7905 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/rep-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.66 2011/08/07 17:39:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.67 2011/09/12 14:04:55 pacho Exp $
+
+*rep-gtk-0.90.7 (12 Sep 2011)
+
+ 12 Sep 2011; Pacho Ramos <pacho@gentoo.org> +rep-gtk-0.90.7.ebuild:
+ Version bump, drop .la files.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> rep-gtk-0.90.3.ebuild:
alpha/ia64/sparc stable wrt #376345
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild
new file mode 100644
index 000000000000..a9823c3055c1
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.90.7.ebuild,v 1.1 2011/09/12 14:04:55 pacho Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+SRC_URI="http://download.tuxfamily.org/librep/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24.0:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog README* TODO
+}