summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-09 13:59:54 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-09 13:59:54 +0000
commit2adf6086260579a451104914ea93a1b3c3bced0e (patch)
tree5b19f15f9311382a6926735a03f2cd178de9b47e /x11-libs/rep-gtk
parenttoday is 9 not 8 (diff)
downloadgentoo-2-2adf6086260579a451104914ea93a1b3c3bced0e.tar.gz
gentoo-2-2adf6086260579a451104914ea93a1b3c3bced0e.tar.bz2
gentoo-2-2adf6086260579a451104914ea93a1b3c3bced0e.zip
Modified dpes.
Diffstat (limited to 'x11-libs/rep-gtk')
-rw-r--r--x11-libs/rep-gtk/ChangeLog5
-rw-r--r--x11-libs/rep-gtk/files/digest-rep-gtk-20020524-r11
-rw-r--r--x11-libs/rep-gtk/rep-gtk-20020524-r1.ebuild55
3 files changed, 60 insertions, 1 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index f7ec75367154..d344e8c83082 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for x11-libs/rep-gtk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.2 2002/05/27 00:31:25 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.3 2002/06/09 13:59:54 stroke Exp $
+*rep-gtk-20020524-r1 (09 Jun 2002)
+ 09 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> rep-gtk-20020524-r1.ebuild :
+ Modified and added deps. "Workaorund" to #3528 :)
*rep-gtk-20020524 (27 May 2002)
27 May 2002; Spider <spider@gentoo.org> rep-gtk-20020524.ebuild :
diff --git a/x11-libs/rep-gtk/files/digest-rep-gtk-20020524-r1 b/x11-libs/rep-gtk/files/digest-rep-gtk-20020524-r1
new file mode 100644
index 000000000000..2354a6adac83
--- /dev/null
+++ b/x11-libs/rep-gtk/files/digest-rep-gtk-20020524-r1
@@ -0,0 +1 @@
+MD5 f8e665f588929cc5a5df9b1c72d54ea9 rep-gtk-2002-05-24.tar.bz2 131849
diff --git a/x11-libs/rep-gtk/rep-gtk-20020524-r1.ebuild b/x11-libs/rep-gtk/rep-gtk-20020524-r1.ebuild
new file mode 100644
index 000000000000..62f13de48b7d
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-20020524-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-20020524-r1.ebuild,v 1.1 2002/06/09 13:59:54 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+MY_P=${PN}-2002-05-24
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Shared library implementing a Lisp dialect"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://librep.sourceforge.net/"
+
+# I think we should use gnome? ( ... ) and add "use gnome" with $myopts as rep-gtk
+# can be compiled without gnome support, no ?
+# I'm just adding deps to fix bug #3528 this time btw.
+# stroke@gentoo.org
+
+DEPEND="virtual/glibc
+ >=dev-util/pkgconfig-0.12.0
+ >=x11-libs/gtk+-2.0.3
+ >=dev-libs/librep-${PV}
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libgnomecanvas-2.0.0
+ >=gnome-base/libglade-2.0.0"
+
+src_compile() {
+ local myconf
+
+ ./configure --host=${CHOST} \
+ --with-libglade \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-gnome --with-libglade \
+ --infodir=/usr/share/info || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+# insinto /usr/include
+# doins src/rep_config.h
+# dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC
+# docinto doc
+# dodoc doc/*
+}