summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-07-20 03:22:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-07-20 03:22:45 +0000
commitf636404d269374ecd078e756ae012f1b1900eb27 (patch)
treeaf19920047395142c6f8faf95232b93c6ba59a56 /x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild
parentversion bump, bug #329025, by Hypnos <hypnos75@gmail.com> (diff)
downloadgentoo-2-f636404d269374ecd078e756ae012f1b1900eb27.tar.gz
gentoo-2-f636404d269374ecd078e756ae012f1b1900eb27.tar.bz2
gentoo-2-f636404d269374ecd078e756ae012f1b1900eb27.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild')
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild b/x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild
new file mode 100644
index 000000000000..558e0c4937a7
--- /dev/null
+++ b/x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.6.10.ebuild,v 1.1 2010/07/20 03:22:45 aballier Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.splitted-desktop.com/~gbeauchesne/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND="x11-libs/libva[opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}