summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-09-16 05:07:14 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-09-16 05:07:14 +0000
commit21d20e5cf357df4fe00ac81526f6aa651a195146 (patch)
tree9194eedef6cb2847ab0f48c8575ce0bb6af7b859 /x11-libs/wxmozilla
parentMarked ~ppc for bug #188450. (diff)
downloadgentoo-2-21d20e5cf357df4fe00ac81526f6aa651a195146.tar.gz
gentoo-2-21d20e5cf357df4fe00ac81526f6aa651a195146.tar.bz2
gentoo-2-21d20e5cf357df4fe00ac81526f6aa651a195146.zip
Fix build error with python-2.5. Bug #190812 by Anton Romanov.
(Portage version: 2.1.3.9)
Diffstat (limited to 'x11-libs/wxmozilla')
-rw-r--r--x11-libs/wxmozilla/ChangeLog7
-rw-r--r--x11-libs/wxmozilla/files/wxmozilla-0.5.7-python-2.5.patch26
-rw-r--r--x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild13
3 files changed, 39 insertions, 7 deletions
diff --git a/x11-libs/wxmozilla/ChangeLog b/x11-libs/wxmozilla/ChangeLog
index 226265b483ba..1a31e37ab157 100644
--- a/x11-libs/wxmozilla/ChangeLog
+++ b/x11-libs/wxmozilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/wxmozilla
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.13 2007/05/19 05:42:42 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.14 2007/09/16 05:07:13 dirtyepic Exp $
+
+ 16 Sep 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxmozilla-0.5.7-python-2.5.patch,
+ wxmozilla-0.5.7_pre20070102.ebuild:
+ Fix build error with python-2.5. Bug #190812 by Anton Romanov.
19 May 2007; Ryan Hill <dirtyepic@gentoo.org>
wxmozilla-0.5.7_pre20070102.ebuild:
diff --git a/x11-libs/wxmozilla/files/wxmozilla-0.5.7-python-2.5.patch b/x11-libs/wxmozilla/files/wxmozilla-0.5.7-python-2.5.patch
new file mode 100644
index 000000000000..b65a9ad5beae
--- /dev/null
+++ b/x11-libs/wxmozilla/files/wxmozilla-0.5.7-python-2.5.patch
@@ -0,0 +1,26 @@
+diff -Naur wxMozilla-orig/wxPython/contrib/mozilla25/gtk/mozilla_wrap.cpp wxMozilla/wxPython/contrib/mozilla25/gtk/mozilla_wrap.cpp
+--- wxMozilla-orig/wxPython/contrib/mozilla25/gtk/mozilla_wrap.cpp 2006-04-23 09:15:15.000000000 -0600
++++ wxMozilla/wxPython/contrib/mozilla25/gtk/mozilla_wrap.cpp 2007-09-15 23:01:01.000000000 -0600
+@@ -1228,7 +1228,7 @@
+ obj = pyobj;
+ if (PyCFunction_Check(obj)) {
+ /* here we get the method pointer for callbacks */
+- char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
++ const char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
+ c = doc ? strstr(doc, "swig_ptr: ") : 0;
+ if (c) {
+ c = ty ? SWIG_UnpackVoidPtr(c + 10, &vptr, ty->name) : 0;
+@@ -8120,11 +8120,11 @@
+ swig_type_info **types_initial) {
+ size_t i;
+ for (i = 0; methods[i].ml_name; ++i) {
+- char *c = methods[i].ml_doc;
++ const char *c = methods[i].ml_doc;
+ if (c && (c = strstr(c, "swig_ptr: "))) {
+ int j;
+ swig_const_info *ci = 0;
+- char *name = c + 10;
++ const char *name = c + 10;
+ for (j = 0; const_table[j].type; ++j) {
+ if (strncmp(const_table[j].name, name,
+ strlen(const_table[j].name)) == 0) {
diff --git a/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild b/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
index 76550c7e026b..c2e1d000a173 100644
--- a/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
+++ b/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild,v 1.3 2007/05/19 05:42:42 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild,v 1.4 2007/09/16 05:07:13 dirtyepic Exp $
inherit eutils wxwidgets
@@ -19,11 +19,10 @@ HOMEPAGE="http://wxmozilla.sourceforge.net/"
# !firefox? ( >=www-client/seamonkey-1.0.0 )
# python? ( dev-lang/python
# >=dev-python/wxpython-2.6.3 )"
-DEPEND="
- =x11-libs/wxGTK-2.6*
- >=www-client/mozilla-firefox-2.0
- python? ( dev-lang/python
- =dev-python/wxpython-2.6* )"
+DEPEND="=x11-libs/wxGTK-2.6*
+ >=www-client/mozilla-firefox-2.0
+ python? ( dev-lang/python
+ =dev-python/wxpython-2.6* )"
SLOT="0"
LICENSE="wxWinLL-3"
@@ -34,6 +33,8 @@ S="${WORKDIR}/wxMozilla"
src_unpack() {
unpack ${A}
cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.5.7-python-2.5.patch
}
src_compile() {