summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-17 17:35:57 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-17 17:35:57 +0000
commit16a5a78efab991da79813824039f4378d12c7757 (patch)
tree75300691c825ebf1524cd7b33d2cfd96c37e68dc /x11-libs/xcb-util-cursor
parentEnable multilib support. (diff)
downloadgentoo-2-16a5a78efab991da79813824039f4378d12c7757.tar.gz
gentoo-2-16a5a78efab991da79813824039f4378d12c7757.tar.bz2
gentoo-2-16a5a78efab991da79813824039f4378d12c7757.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-libs/xcb-util-cursor')
-rw-r--r--x11-libs/xcb-util-cursor/ChangeLog8
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1-r1.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-libs/xcb-util-cursor/ChangeLog b/x11-libs/xcb-util-cursor/ChangeLog
index 89705cda4020..7f049ef583ac 100644
--- a/x11-libs/xcb-util-cursor/ChangeLog
+++ b/x11-libs/xcb-util-cursor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xcb-util-cursor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-cursor/ChangeLog,v 1.11 2014/06/08 09:16:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-cursor/ChangeLog,v 1.12 2014/06/17 17:35:57 mgorny Exp $
+
+*xcb-util-cursor-0.1.1-r1 (17 Jun 2014)
+
+ 17 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +xcb-util-cursor-0.1.1-r1.ebuild:
+ Enable multilib support.
08 Jun 2014; Agostino Sarubbo <ago@gentoo.org> xcb-util-cursor-0.1.1.ebuild:
Stable for arm, wrt bug #500368
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1-r1.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..5773315987a2
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1-r1.ebuild,v 1.1 2014/06/17 17:35:57 mgorny Exp $
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-cursor"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xcb-proto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_src_configure
+}