summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-14 15:57:56 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-14 15:57:56 +0000
commit913a4616fd7e25e317b842e79638c569f12f9a86 (patch)
treef290133e1c0d5c70e9a1fdaba0f9d632b768293e /x11-libs/xcb-util-cursor
parentLinux patch 3.11.8 (diff)
downloadgentoo-2-913a4616fd7e25e317b842e79638c569f12f9a86.tar.gz
gentoo-2-913a4616fd7e25e317b842e79638c569f12f9a86.tar.bz2
gentoo-2-913a4616fd7e25e317b842e79638c569f12f9a86.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs/xcb-util-cursor')
-rw-r--r--x11-libs/xcb-util-cursor/ChangeLog8
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-libs/xcb-util-cursor/ChangeLog b/x11-libs/xcb-util-cursor/ChangeLog
index 7006272b1698..7ee5ebfbdbf7 100644
--- a/x11-libs/xcb-util-cursor/ChangeLog
+++ b/x11-libs/xcb-util-cursor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xcb-util-cursor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-cursor/ChangeLog,v 1.1 2013/10/04 15:41:05 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-cursor/ChangeLog,v 1.2 2013/11/14 15:57:56 chithanh Exp $
+
+*xcb-util-cursor-0.1.1 (14 Nov 2013)
+
+ 14 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xcb-util-cursor-0.1.1.ebuild:
+ Version bump.
*xcb-util-cursor-0.1.0 (04 Oct 2013)
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1.ebuild
new file mode 100644
index 000000000000..9168608601a0
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.1.ebuild,v 1.1 2013/11/14 15:57:56 chithanh Exp $
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-cursor"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}
+ x11-proto/xcb-proto
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4 )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_pkg_setup
+}