summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-26 09:52:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-26 09:52:47 +0000
commit6c158c520f038d3d92dbf76bbada72bf60cb0270 (patch)
treed16f9d7b64cc97a7ebb5757147f997933406c5d3 /x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild
parentVersion bump to 0.3.8. This is first split release. (diff)
downloadgentoo-2-6c158c520f038d3d92dbf76bbada72bf60cb0270.tar.gz
gentoo-2-6c158c520f038d3d92dbf76bbada72bf60cb0270.tar.bz2
gentoo-2-6c158c520f038d3d92dbf76bbada72bf60cb0270.zip
Version bump to 0.3.8. This is first split release.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild')
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild b/x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild
new file mode 100644
index 000000000000..e78109123dd4
--- /dev/null
+++ b/x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-image/xcb-util-image-0.3.8.ebuild,v 1.1 2011/04/26 09:52:47 scarabeus Exp $
+
+EAPI=4
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-image"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4 )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_pkg_setup
+} \ No newline at end of file