summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-17 17:36:11 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-17 17:36:11 +0000
commitc79e60ecfe180beda29312c1c38d736aa3fdc4d0 (patch)
tree502a4dbb933d0a2fe93b20fa070cc45371ce7280 /x11-libs/xcb-util-keysyms
parentEnable multilib support. (diff)
downloadgentoo-2-c79e60ecfe180beda29312c1c38d736aa3fdc4d0.tar.gz
gentoo-2-c79e60ecfe180beda29312c1c38d736aa3fdc4d0.tar.bz2
gentoo-2-c79e60ecfe180beda29312c1c38d736aa3fdc4d0.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-libs/xcb-util-keysyms')
-rw-r--r--x11-libs/xcb-util-keysyms/ChangeLog10
-rw-r--r--x11-libs/xcb-util-keysyms/xcb-util-keysyms-0.3.9-r1.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/x11-libs/xcb-util-keysyms/ChangeLog b/x11-libs/xcb-util-keysyms/ChangeLog
index 52adbffad4b6..337053d3c236 100644
--- a/x11-libs/xcb-util-keysyms/ChangeLog
+++ b/x11-libs/xcb-util-keysyms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xcb-util-keysyms
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-keysyms/ChangeLog,v 1.18 2013/02/23 02:46:08 zmedico Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-keysyms/ChangeLog,v 1.19 2014/06/17 17:36:11 mgorny Exp $
+
+*xcb-util-keysyms-0.3.9-r1 (17 Jun 2014)
+
+ 17 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +xcb-util-keysyms-0.3.9-r1.ebuild:
+ Enable multilib support.
23 Feb 2013; Zac Medico <zmedico@gentoo.org> xcb-util-keysyms-0.3.9.ebuild:
Add ~arm-linux keyword.
diff --git a/x11-libs/xcb-util-keysyms/xcb-util-keysyms-0.3.9-r1.ebuild b/x11-libs/xcb-util-keysyms/xcb-util-keysyms-0.3.9-r1.ebuild
new file mode 100644
index 000000000000..93ed38aebf7d
--- /dev/null
+++ b/x11-libs/xcb-util-keysyms/xcb-util-keysyms-0.3.9-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-keysyms/xcb-util-keysyms-0.3.9-r1.ebuild,v 1.1 2014/06/17 17:36:11 mgorny Exp $
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-keysyms"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/xcb-util-${PV}[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.4[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_src_configure
+}