summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-12-27 15:12:59 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-12-27 15:12:59 +0000
commit482772d1c6701e456c97324b5fdb3fe7c7268b69 (patch)
tree46259153cc23c2e35a6fbd8ba574e63ebb671808 /x11-libs/xforms
parentMarked ~hppa (bug #448162). (diff)
downloadgentoo-2-482772d1c6701e456c97324b5fdb3fe7c7268b69.tar.gz
gentoo-2-482772d1c6701e456c97324b5fdb3fe7c7268b69.tar.bz2
gentoo-2-482772d1c6701e456c97324b5fdb3fe7c7268b69.zip
Migrate to EAPI 5. Make static libs optional and prune .la files.
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'x11-libs/xforms')
-rw-r--r--x11-libs/xforms/ChangeLog8
-rw-r--r--x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/xforms/ChangeLog b/x11-libs/xforms/ChangeLog
index f2d3c391a765..ad98575da17f 100644
--- a/x11-libs/xforms/ChangeLog
+++ b/x11-libs/xforms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xforms
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/ChangeLog,v 1.50 2012/05/21 18:12:18 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/ChangeLog,v 1.51 2012/12/27 15:12:59 kensington Exp $
+
+*xforms-1.0.93_p1-r1 (27 Dec 2012)
+
+ 27 Dec 2012; Michael Palimaka <kensington@gentoo.org>
+ +xforms-1.0.93_p1-r1.ebuild:
+ Migrate to EAPI 5. Make static libs optional and prune .la files.
21 May 2012; Kacper Kowalik <xarthisius@gentoo.org> xforms-1.0.90-r1.ebuild:
Add missing inheritance of eutils.eclass
diff --git a/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild b/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild
new file mode 100644
index 000000000000..2f41e90273cb
--- /dev/null
+++ b/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0.93_p1-r1.ebuild,v 1.1 2012/12/27 15:12:59 kensington Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_P="${P/_/s}"
+
+DESCRIPTION="A graphical user interface toolkit for X"
+HOMEPAGE="http://www.nongnu.org/xforms/"
+SRC_URI="http://savannah.nongnu.org/download/xforms/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="doc opengl static-libs"
+
+RDEPEND="virtual/jpeg
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog NEWS README )
+
+src_prepare() {
+ rm "${S}"/config/libtool.m4 "${S}"/acinclude.m4
+ AT_M4DIR=config eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable opengl gl) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}