summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-02-02 04:03:56 +0000
committerAlex Alexander <wired@gentoo.org>2013-02-02 04:03:56 +0000
commit3f4ba024e8179b38853d9879e15075923cbe405e (patch)
tree1365ee2513ff649f69b1546f6e8de138ade52049 /x11-libs/xosd
parentBump (diff)
downloadgentoo-2-3f4ba024e8179b38853d9879e15075923cbe405e.tar.gz
gentoo-2-3f4ba024e8179b38853d9879e15075923cbe405e.tar.bz2
gentoo-2-3f4ba024e8179b38853d9879e15075923cbe405e.zip
fixed broken xosd-config, bug #286632
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'x11-libs/xosd')
-rw-r--r--x11-libs/xosd/ChangeLog10
-rw-r--r--x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch15
-rw-r--r--x11-libs/xosd/xosd-2.2.14-r2.ebuild49
3 files changed, 72 insertions, 2 deletions
diff --git a/x11-libs/xosd/ChangeLog b/x11-libs/xosd/ChangeLog
index 82baa213d106..bcd43f7b6cff 100644
--- a/x11-libs/xosd/ChangeLog
+++ b/x11-libs/xosd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xosd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/ChangeLog,v 1.82 2012/06/02 15:39:30 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/ChangeLog,v 1.83 2013/02/02 04:03:56 wired Exp $
+
+*xosd-2.2.14-r2 (02 Feb 2013)
+
+ 02 Feb 2013; Alex Alexander <wired@gentoo.org> +xosd-2.2.14-r2.ebuild,
+ +files/xosd-config-incorrect-dup-filter-fix.patch:
+ fixed broken xosd-config, bug #286632
02 Jun 2012; Alexis Ballier <aballier@gentoo.org> xosd-2.2.14-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch b/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch
new file mode 100644
index 000000000000..8446297f15ce
--- /dev/null
+++ b/x11-libs/xosd/files/xosd-config-incorrect-dup-filter-fix.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=286632
+
+This patch disables reordering and duplicate removing for non-libs arguments, thus --param and alike gcc options may be used safe now.
+
+written by Andrew Savchenko
+--- script/xosd-config.in.orig
++++ script/xosd-config.in
+@@ -161,7 +161,6 @@
+ fi;;
+ *)
+ case " $af_other_flags " in
+- *\ $i\ *) ;; # already there
+ *) af_other_flags="$af_other_flags $i" ;; # add it to output
+ esac ;;
+ esac
diff --git a/x11-libs/xosd/xosd-2.2.14-r2.ebuild b/x11-libs/xosd/xosd-2.2.14-r2.ebuild
new file mode 100644
index 000000000000..553e98a35cb9
--- /dev/null
+++ b/x11-libs/xosd/xosd-2.2.14-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/xosd-2.2.14-r2.ebuild,v 1.1 2013/02/02 04:03:56 wired Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Library for overlaying text in X-Windows X-On-Screen-Display plus binary for sending text from CLI"
+HOMEPAGE="https://sourceforge.net/projects/libxosd/"
+SRC_URI="mirror://debian/pool/main/x/xosd/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/xosd/${PN}_${PV}-1.diff.gz
+ http://digilander.libero.it/dgp85/gentoo/${PN}-gentoo-m4-1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="xinerama"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ media-fonts/font-misc-misc"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${DISTDIR}"/${PN}_${PV}-1.diff.gz
+ # bug #286632
+ epatch "${FILESDIR}"/"${PN}"-config-incorrect-dup-filter-fix.patch
+
+ AT_M4DIR="${WORKDIR}/m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable xinerama)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}