summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-03-07 22:19:17 +0000
committerUlrich Müller <ulm@gentoo.org>2008-03-07 22:19:17 +0000
commit2cc621d2f184cd73b43b3f2bf35bdbb99bd6c9bf (patch)
treea2c9fcb5f4e01a8b676c43325fa54fe1d0c83e52 /x11-libs
parentStable on amd64, bug #210526 (diff)
downloadgentoo-2-2cc621d2f184cd73b43b3f2bf35bdbb99bd6c9bf.tar.gz
gentoo-2-2cc621d2f184cd73b43b3f2bf35bdbb99bd6c9bf.tar.bz2
gentoo-2-2cc621d2f184cd73b43b3f2bf35bdbb99bd6c9bf.zip
Fix syntax in pkg_setup, so that it works also with older bash versions.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog5
-rw-r--r--x11-libs/openmotif/openmotif-2.3.0-r1.ebuild11
2 files changed, 11 insertions, 5 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index aae3e7a8c20c..99eb3c11076d 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.167 2008/03/07 15:16:13 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.168 2008/03/07 22:19:17 ulm Exp $
+
+ 07 Mar 2008; Ulrich Mueller <ulm@gentoo.org> openmotif-2.3.0-r1.ebuild:
+ Fix syntax in pkg_setup, so that it works also with older bash versions.
07 Mar 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml,
-openmotif-2.3.0.ebuild:
diff --git a/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild b/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
index 7e0ae588de3f..46b5238d765d 100644
--- a/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild,v 1.15 2008/03/07 15:11:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild,v 1.16 2008/03/07 22:19:17 ulm Exp $
inherit eutils flag-o-matic multilib autotools
@@ -33,11 +33,13 @@ PROVIDE="virtual/motif"
pkg_setup() {
# clean up orphaned cruft left over by motif-config
- local i count=0
+ local i l count=0
for i in "${ROOT}"usr/bin/{mwm,uil,xmbind} \
"${ROOT}"usr/include/{Xm,uil,Mrm} \
"${ROOT}"usr/$(get_libdir)/lib{Xm,Uil,Mrm}.*; do
- if [[ -L "${i}" && $(readlink "${i}") =~ (openmo|less)tif- ]]; then
+ [[ -L "${i}" ]] || continue
+ l=$(readlink "${i}")
+ if [[ ${l} == *openmotif-* || ${l} == *lesstif-* ]]; then
einfo "Cleaning up orphaned ${i} symlink ..."
rm -f "${i}"
fi
@@ -45,7 +47,8 @@ pkg_setup() {
cd "${ROOT}"usr/share/man
for i in $(find . -type l); do
- if [[ $(readlink "${i}") =~ -(openmo|less)tif- ]]; then
+ l=$(readlink "${i}")
+ if [[ ${l} == *-openmotif-* || ${l} == *-lesstif-* ]]; then
(( count++ ))
rm -f "${i}"
fi