summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-08 15:24:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-08 15:24:31 +0000
commit3473d49586b2d71912339804cb145f19da37bece (patch)
tree33294c785397e5c5e7c2192f55bd04f8e77e45a2 /x11-libs
parentrevbump -> EAPI 5 (diff)
downloadgentoo-2-3473d49586b2d71912339804cb145f19da37bece.tar.gz
gentoo-2-3473d49586b2d71912339804cb145f19da37bece.tar.bz2
gentoo-2-3473d49586b2d71912339804cb145f19da37bece.zip
Version bump. Drop USE=doc conditionals, it wasn't used and always installed as per gnome team policy already.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libnotify/ChangeLog8
-rw-r--r--x11-libs/libnotify/libnotify-0.7.6.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/x11-libs/libnotify/ChangeLog b/x11-libs/libnotify/ChangeLog
index 61b0661fd938..27dcfaf5ec2d 100644
--- a/x11-libs/libnotify/ChangeLog
+++ b/x11-libs/libnotify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libnotify
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.103 2013/05/01 11:14:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/ChangeLog,v 1.104 2013/09/08 15:24:31 eva Exp $
+
+*libnotify-0.7.6 (08 Sep 2013)
+
+ 08 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org> +libnotify-0.7.6.ebuild:
+ Version bump. Drop USE=doc conditionals, it wasn't used and always installed
+ as per gnome team policy already.
01 May 2013; Agostino Sarubbo <ago@gentoo.org> libnotify-0.7.5-r1.ebuild:
Stable for sh, wrt bug #466004
diff --git a/x11-libs/libnotify/libnotify-0.7.6.ebuild b/x11-libs/libnotify/libnotify-0.7.6.ebuild
new file mode 100644
index 000000000000..65811b082a57
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.7.6.ebuild,v 1.1 2013/09/08 15:24:31 eva Exp $
+
+EAPI=5
+inherit autotools gnome.org
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="http://git.gnome.org/browse/libnotify"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="app-admin/eselect-notify-send
+ >=dev-libs/glib-2.26
+ x11-libs/gdk-pixbuf:2
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.32
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+ test? ( x11-libs/gtk+:3 )"
+PDEPEND="virtual/notification-daemon"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+
+ if ! use test; then
+ sed -i -e '/PKG_CHECK_MODULES(TESTS/d' configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}