summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-14 10:09:57 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-14 10:09:57 +0000
commit50b4865c9a2e7b8a70b85550536832c1428fd620 (patch)
treef1c1bbe03d9b4ee5462bf01fe46632b10cae80e1 /x11-libs
parentUnquote ${A}. (diff)
downloadgentoo-2-50b4865c9a2e7b8a70b85550536832c1428fd620.tar.gz
gentoo-2-50b4865c9a2e7b8a70b85550536832c1428fd620.tar.bz2
gentoo-2-50b4865c9a2e7b8a70b85550536832c1428fd620.zip
Install libraries and include files without slotting, bug 210021.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog11
-rw-r--r--x11-libs/openmotif/files/Mwm.defaults14
-rw-r--r--x11-libs/openmotif/files/motif-config-2.391
-rw-r--r--x11-libs/openmotif/openmotif-2.3.0-r1.ebuild106
-rw-r--r--x11-libs/openmotif/openmotif-2.3.0.ebuild6
5 files changed, 224 insertions, 4 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 0127544e925d..f10ebd5b1031 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.150 2008/02/13 14:33:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.151 2008/02/14 10:09:57 ulm Exp $
+
+*openmotif-2.3.0-r1 (14 Feb 2008)
+
+ 14 Feb 2008; Ulrich Mueller <ulm@gentoo.org> +files/motif-config-2.3,
+ +files/Mwm.defaults, openmotif-2.3.0.ebuild, +openmotif-2.3.0-r1.ebuild:
+ Install libraries and include files without slotting. Install application
+ defaults for Mwm and a stripped-down motif-config. Ebuild by Jakub Moc
+ <jakub@gentoo.org>, bug 210021. Remove demo binaries. Fix symlink for
+ system.mwmrc. Drop mips to unstable.
13 Feb 2008; Raúl Porcel <armin76@gentoo.org> openmotif-2.3.0.ebuild:
alpha/ia64/sparc stable wrt #204265
diff --git a/x11-libs/openmotif/files/Mwm.defaults b/x11-libs/openmotif/files/Mwm.defaults
new file mode 100644
index 000000000000..ea91b6fb8d86
--- /dev/null
+++ b/x11-libs/openmotif/files/Mwm.defaults
@@ -0,0 +1,14 @@
+Mwm*fontList: variable
+Mwm*iconClick: False
+Mwm*iconPlacement: top left
+Mwm*moveOpaque: True
+Mwm*rootButtonClick: True
+Mwm*foreground: #000000
+Mwm*background: #B8B8C0
+Mwm*enableThinThickness: True
+Mwm*enableEtchedInMenu: True
+Mwm*menu*fontList: -adobe-helvetica-medium-r-*--*-120-*-*-*-*-*-*
+Mwm*client*title*fontList: -adobe-helvetica-bold-r-*--*-100-*-*-*-*-*-*
+Mwm*icon*fontList: -adobe-helvetica-bold-r-*--*-80-*-*-*-*-*-*
+Mwm*feedback*fontList: -adobe-helvetica-bold-r-*--*-100-*-*-*-*-*-*
+Mwm*multiClickTime: 300
diff --git a/x11-libs/openmotif/files/motif-config-2.3 b/x11-libs/openmotif/files/motif-config-2.3
new file mode 100644
index 000000000000..fe225e7c77bb
--- /dev/null
+++ b/x11-libs/openmotif/files/motif-config-2.3
@@ -0,0 +1,91 @@
+#!/bin/bash
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# based on gcc-config by Martin Schlemmer <azarah@gentoo.org
+# Author: Heinrich Wendel <lanius@gentoo.org>
+
+# Stripped down minimal version for backwards compatibility only.
+# We now just provide the info that other applications might use
+# to compile and link against openmotif - Jakub Moc <jakub@gentoo.org>
+
+usage() {
+cat << "USAGE_END"
+Usage: motif-config [option]
+
+Options:
+
+ -L, --get-lib-path Print path where openmotif libraries are located.
+
+ -I, --get-inc-path Print path where openmotif includes are located.
+
+ --libs Print link flags for openmotif
+
+ --cflags Print compilation flags for openmotif
+
+USAGE_END
+ exit $1
+}
+[[ $# -lt 1 ]] && usage 1
+[[ $# -gt 2 ]] && usage 1
+
+get_lib_path() {
+ echo "/usr/@@LIBDIR@@/"
+ exit 0
+}
+
+get_inc_path() {
+ echo "/usr/include/"
+ exit 0
+}
+
+get_cflags() {
+ echo "-I/usr/include/"
+ exit 0
+}
+
+get_libs() {
+ echo "-L/usr/@@LIBDIR@@/"
+ exit 0
+}
+
+for x in "$@"; do
+ case "${x}" in
+ -L|--get-lib-path)
+ [[ $# -gt 2 ]] && usage 1
+ get_lib_path $2
+ ;;
+
+ -I|--get-inc-path)
+ [[ $# -gt 2 ]] && usage 1
+ get_inc_path $2
+ ;;
+
+ --cflags)
+ [[ $# -gt 2 ]] && usage 1
+ get_cflags $2
+ ;;
+
+ --libs)
+ [[ $# -gt 2 ]] && usage 1
+ get_libs $2
+ ;;
+
+ -h|--help)
+ usage 0
+ ;;
+
+ -v|--version)
+ echo "motif-config-2.3"
+ exit 0
+ ;;
+
+ -*)
+ usage 1
+ ;;
+
+ *)
+ usage 1
+ ;;
+
+ esac
+done
diff --git a/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild b/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..4ed399667b1b
--- /dev/null
+++ b/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0-r1.ebuild,v 1.1 2008/02/14 10:09:57 ulm Exp $
+
+inherit flag-o-matic multilib autotools
+
+DESCRIPTION="Open Motif"
+HOMEPAGE="http://www.motifzone.org/"
+SRC_URI="ftp://ftp.ics.com/openmotif/2.3/${PV}/${P}.tar.gz
+ doc? ( http://www.motifzone.net/files/documents/${P}-manual.pdf.tgz )"
+
+LICENSE="MOTIF"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples jpeg png xft"
+
+# make people unmerge motif-config and all previous slots
+# since the slotting is finally gone now
+RDEPEND="!x11-libs/motif-config
+ !x11-libs/lesstif
+ !<x11-libs/openmotif-2.3.0
+ x11-libs/libXmu
+ x11-libs/libXaw
+ x11-libs/libXp
+ xft? ( x11-libs/libXft )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )"
+DEPEND="${RDEPEND}
+ x11-misc/xbitmaps
+ x11-proto/printproto"
+
+PROVIDE="virtual/motif"
+
+src_compile() {
+ # get around some LANG problems in make (#15119)
+ unset LANG
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # multilib includes don't work right in this package...
+ has_multilib_profile && append-flags "-I$(get_ml_incdir)"
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ econf --with-x \
+ $(use_enable xft) \
+ $(use_enable jpeg) \
+ $(use_enable png)
+
+ emake -j1 || die "emake failed"
+}
+
+pkg_preinst() {
+ # clean up orphaned cruft left over by motif-config
+ local i
+ local stalesyms="usr/bin/mwm \
+ usr/bin/uil \
+ usr/bin/xmbind \
+ usr/include/Xm \
+ usr/include/uil \
+ usr/include/Mrm"
+
+ for i in ${stalesyms} ; do
+ if [[ -L "${ROOT}"${i} ]] ; then
+ einfo "Cleaning up orphaned ${ROOT}${i} symlink ..."
+ rm -f "${ROOT}"${i}
+ fi
+ done
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ newbin "${FILESDIR}"/motif-config-2.3 motif-config
+ dosed "s:@@LIBDIR@@:$(get_libdir):g" /usr/bin/motif-config
+
+ # mwm default configs
+ insinto /etc/X11/app-defaults
+ doins "${FILESDIR}"/Mwm.defaults
+
+ for f in /usr/share/man/man1/mwm.1 /usr/share/man/man4/mwmrc.4; do
+ dosed 's:/usr/lib/X11/\(.*system\\&\.mwmrc\):/etc/X11/mwm/\1:g' ${f}
+ dosed 's:/usr/lib/X11/app-defaults:/etc/X11/app-defaults:g' ${f}
+ done
+
+ dodir /etc/X11/mwm
+ mv -f "${D}"/usr/$(get_libdir)/X11/system.mwmrc "${D}"/etc/X11/mwm
+ dosym /etc/X11/mwm/system.mwmrc /usr/$(get_libdir)/X11/
+
+ # cleanup
+ einfo "Removing demo applications ..."
+ find "${D}"/usr/bin/ -type f ! -name motif-config ! -name mwm \
+ ! -name uil ! -name xmbind | xargs rm -f
+
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/demos
+ mv "${D}"/usr/share/Xm/* "${D}"/usr/share/doc/${PF}/demos
+ fi
+ rm -rf "${D}"/usr/share/Xm
+
+ # documentation
+ dodoc README RELEASE RELNOTES BUGREPORT TODO
+ use doc && cp "${WORKDIR}"/*.pdf "${D}"/usr/share/doc/${PF}
+}
diff --git a/x11-libs/openmotif/openmotif-2.3.0.ebuild b/x11-libs/openmotif/openmotif-2.3.0.ebuild
index 442f20a34d47..f7c645fcc751 100644
--- a/x11-libs/openmotif/openmotif-2.3.0.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0.ebuild,v 1.13 2008/02/13 14:33:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.0.ebuild,v 1.14 2008/02/14 10:09:57 ulm Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.6"
@@ -13,8 +13,8 @@ SRC_URI="ftp://ftp.ics.com/openmotif/2.3/${PV}/${P}.tar.gz
doc? ( http://www.motifzone.net/files/documents/${P}-manual.pdf.tgz )"
LICENSE="MOTIF"
-SLOT="2.3"
-KEYWORDS="alpha ~amd64 ~arm hppa ia64 mips ~ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm hppa ia64 ~mips ~ppc ppc64 ~sh sparc x86 ~x86-fbsd"
IUSE="doc xft jpeg png examples"
RDEPEND="