summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-08-21 11:25:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-08-21 11:25:33 +0000
commit57b075890f40c42ae783f9968b0ed18b340f94d1 (patch)
treefb0fb9040f01a68797180cf67c36cb99eaee7387 /x11-libs
parentFix building with media-libs/jpeg >= 9a wrt #481688 by Maurice van der Pot (diff)
downloadgentoo-2-57b075890f40c42ae783f9968b0ed18b340f94d1.tar.gz
gentoo-2-57b075890f40c42ae783f9968b0ed18b340f94d1.tar.bz2
gentoo-2-57b075890f40c42ae783f9968b0ed18b340f94d1.zip
Fix building with media-libs/jpeg >= 9a wrt #479774 by Gabriel Marcano
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/ChangeLog6
-rw-r--r--x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch22
-rw-r--r--x11-libs/fltk/fltk-1.3.2_p10088.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index c53840951595..9cb38d041bbf 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.239 2014/02/02 11:15:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.240 2014/08/21 11:25:33 ssuominen Exp $
+
+ 21 Aug 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/fltk-1.3.2-jpeg-9a.patch, fltk-1.3.2_p10088.ebuild:
+ Fix building with media-libs/jpeg >= 9a wrt #479774 by Gabriel Marcano
*fltk-1.3.2_p10088 (02 Feb 2014)
diff --git a/x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch b/x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch
new file mode 100644
index 000000000000..701f04ca6168
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/479774
+
+--- src/Fl_JPEG_Image.cxx
++++ src/Fl_JPEG_Image.cxx
+@@ -155,7 +155,7 @@
+
+ jpeg_create_decompress(&dinfo);
+ jpeg_stdio_src(&dinfo, fp);
+- jpeg_read_header(&dinfo, 1);
++ jpeg_read_header(&dinfo, TRUE);
+
+ dinfo.quantize_colors = (boolean)FALSE;
+ dinfo.out_color_space = JCS_RGB;
+@@ -337,7 +337,7 @@
+
+ jpeg_create_decompress(&dinfo);
+ jpeg_mem_src(&dinfo, data);
+- jpeg_read_header(&dinfo, 1);
++ jpeg_read_header(&dinfo, TRUE);
+
+ dinfo.quantize_colors = (boolean)FALSE;
+ dinfo.out_color_space = JCS_RGB;
diff --git a/x11-libs/fltk/fltk-1.3.2_p10088.ebuild b/x11-libs/fltk/fltk-1.3.2_p10088.ebuild
index b4af3ba16919..61bf603c98ec 100644
--- a/x11-libs/fltk/fltk-1.3.2_p10088.ebuild
+++ b/x11-libs/fltk/fltk-1.3.2_p10088.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.2_p10088.ebuild,v 1.1 2014/02/02 11:15:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.3.2_p10088.ebuild,v 1.2 2014/08/21 11:25:33 ssuominen Exp $
EAPI=5
@@ -49,7 +49,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.3.1-as-needed.patch \
"${FILESDIR}"/${PN}-1.3.2-desktop.patch \
"${FILESDIR}"/${PN}-1.3.0-share.patch \
- "${FILESDIR}"/${PN}-1.3.2-conf-tests.patch
+ "${FILESDIR}"/${PN}-1.3.2-conf-tests.patch \
+ "${FILESDIR}"/${PN}-1.3.2-jpeg-9a.patch
sed \
-e 's:@HLINKS@::g' -i FL/Makefile.in || die
sed -i \