summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-25 15:35:13 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-25 15:35:13 +0000
commit6354e1cae96f9de6584df75fa979e9740090ad22 (patch)
tree0267e3e1d1577f4afc4303ac0504a78cf661bcd7 /x11-libs
parentAdd prefix support, revbump due to otherwise unresolvable USE deps (diff)
downloadgentoo-2-6354e1cae96f9de6584df75fa979e9740090ad22.tar.gz
gentoo-2-6354e1cae96f9de6584df75fa979e9740090ad22.tar.bz2
gentoo-2-6354e1cae96f9de6584df75fa979e9740090ad22.zip
Add prefix support, revbump due to otherwise unresolvable USE deps
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-core/ChangeLog8
-rw-r--r--x11-libs/qt-core/qt-core-4.6.0-r1.ebuild (renamed from x11-libs/qt-core/qt-core-4.6.0.ebuild)41
2 files changed, 35 insertions, 14 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 87f461790fe1..f9c478584997 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.82 2009/12/23 12:50:15 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.83 2009/12/25 15:35:13 abcd Exp $
+
+*qt-core-4.6.0-r1 (25 Dec 2009)
+
+ 25 Dec 2009; Jonathan Callen <abcd@gentoo.org> -qt-core-4.6.0.ebuild,
+ +qt-core-4.6.0-r1.ebuild:
+ Add prefix support, revbump due to otherwise unresolvable USE deps
23 Dec 2009; Dror Levin <spatz@gentoo.org> qt-core-4.6.0.ebuild,
+files/qt-core-4.6.0-hebrew.patch:
diff --git a/x11-libs/qt-core/qt-core-4.6.0.ebuild b/x11-libs/qt-core/qt-core-4.6.0-r1.ebuild
index 60b1235bcd5d..f671df8be8a3 100644
--- a/x11-libs/qt-core/qt-core-4.6.0.ebuild
+++ b/x11-libs/qt-core/qt-core-4.6.0-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.6.0.ebuild,v 1.3 2009/12/23 12:50:15 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.6.0-r1.ebuild,v 1.1 2009/12/25 15:35:13 abcd Exp $
EAPI="2"
inherit qt4-build
DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework"
SLOT="4"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="doc +glib iconv optimized-qmake qt3support ssl"
RDEPEND="sys-libs/zlib
@@ -16,7 +16,7 @@ RDEPEND="sys-libs/zlib
!<x11-libs/qt-4.4.0:4"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-PDEPEND="qt3support? ( ~x11-libs/qt-gui-${PV}[qt3support] )"
+PDEPEND="qt3support? ( ~x11-libs/qt-gui-${PV}[aqua=,qt3support] )"
QT4_TARGET_DIRECTORIES="
src/tools/bootstrap
@@ -171,9 +171,13 @@ src_install() {
fi
# use freshly built libraries
+ local DYLD_FPATH=
+ [[ -d "${S}"/lib/QtCore.framework ]] \
+ && DYLD_FPATH=$(for x in "${S}/lib/"*.framework; do echo -n ":$x"; done)
+ DYLD_LIBRARY_PATH="${S}/lib${DYLD_FPATH}" \
LD_LIBRARY_PATH="${S}/lib" "${S}"/bin/lrelease translations/*.ts \
|| die "generating translations faied"
- insinto ${QTTRANSDIR}
+ insinto ${QTTRANSDIR#${EPREFIX}}
doins translations/*.qm || die "doins translations failed"
setqtenv
@@ -182,22 +186,31 @@ src_install() {
# List all the multilib libdirs
local libdirs=
for libdir in $(get_all_libdirs); do
- libdirs="${libdirs}:/usr/${libdir}/qt4"
+ libdirs+=:${EPREFIX}/usr/${libdir}/qt4
done
cat <<-EOF > "${T}/44qt4"
- LDPATH=${libdirs:1}
+ LDPATH="${libdirs:1}"
EOF
doenvd "${T}/44qt4"
- dodir /${QTDATADIR}/mkspecs/gentoo
+ dodir ${QTDATADIR#${EPREFIX}}/mkspecs/gentoo
mv "${D}"/${QTDATADIR}/mkspecs/qconfig.pri "${D}${QTDATADIR}"/mkspecs/gentoo \
|| die "Failed to move qconfig.pri"
- sed -i -e '2a#include <Gentoo/gentoo-qconfig.h>\n' \
- "${D}${QTHEADERDIR}"/QtCore/qconfig.h \
- "${D}${QTHEADERDIR}"/Qt/qconfig.h \
- || die "sed for qconfig.h failed"
+ # Framework hacking
+ if use aqua && [[ ${CHOST#*-darwin} -ge 9 ]] ; then
+ #TODO do this better
+ sed -i -e '2a#include <QtCore/Gentoo/gentoo-qconfig.h>\n' \
+ "${D}${QTLIBDIR}"/QtCore.framework/Headers/qconfig.h \
+ || die "sed for qconfig.h failed."
+ dosym "${QTHEADERDIR#${EPREFIX}}"/Gentoo "${QTLIBDIR#${EPREFIX}}"/QtCore.framework/Headers/Gentoo
+ else
+ sed -i -e '2a#include <Gentoo/gentoo-qconfig.h>\n' \
+ "${D}${QTHEADERDIR}"/QtCore/qconfig.h \
+ "${D}${QTHEADERDIR}"/Qt/qconfig.h \
+ || die "sed for qconfig.h failed"
+ fi
if use glib; then
QCONFIG_DEFINE="$(use glib && echo QT_GLIB)
@@ -207,10 +220,12 @@ src_install() {
# remove some unnecessary headers
rm -f "${D}${QTHEADERDIR}"/{Qt,QtCore}/{\
-qatomic_macosx.h,\
qatomic_windows.h,\
qatomic_windowsce.h,\
qt_windows.h}
- keepdir "${QTSYSCONFDIR}"
+ keepdir "${QTSYSCONFDIR#${EPREFIX}}"
+
+ # Framework magic
+ fix_includes
}