summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-30 10:25:11 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-30 10:25:11 +0000
commit6b3dc05b5a69f848e7c9fe4ed56eead2b5dbf95a (patch)
tree56140e1f2c0a55a244370831e70162c91d80543d /x11-libs
parentREQUIRED_USE='doc? ( X )' due upstream bug #643802, move gnome2_src_prepare t... (diff)
downloadgentoo-2-6b3dc05b5a69f848e7c9fe4ed56eead2b5dbf95a.tar.gz
gentoo-2-6b3dc05b5a69f848e7c9fe4ed56eead2b5dbf95a.tar.bz2
gentoo-2-6b3dc05b5a69f848e7c9fe4ed56eead2b5dbf95a.zip
ebuild for qt-openvg
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-openvg/ChangeLog10
-rw-r--r--x11-libs/qt-openvg/Manifest4
-rw-r--r--x11-libs/qt-openvg/metadata.xml11
-rw-r--r--x11-libs/qt-openvg/qt-openvg-4.8.0-r1.ebuild56
4 files changed, 81 insertions, 0 deletions
diff --git a/x11-libs/qt-openvg/ChangeLog b/x11-libs/qt-openvg/ChangeLog
new file mode 100644
index 000000000000..f8b6889f6521
--- /dev/null
+++ b/x11-libs/qt-openvg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/qt-openvg
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/ChangeLog,v 1.1 2012/01/30 10:25:11 wired Exp $
+
+*qt-openvg-4.8.0-r1 (30 Jan 2012)
+
+ 30 Jan 2012; Alex Alexander <wired@gentoo.org> +qt-openvg-4.8.0-r1.ebuild,
+ +metadata.xml:
+ ebuild for qt-openvg
+
diff --git a/x11-libs/qt-openvg/Manifest b/x11-libs/qt-openvg/Manifest
new file mode 100644
index 000000000000..74c65259e847
--- /dev/null
+++ b/x11-libs/qt-openvg/Manifest
@@ -0,0 +1,4 @@
+DIST qt-everywhere-opensource-src-4.8.0.tar.gz 238580694 RMD160 7506dce7743215481fd9fe56920b8a47f07a112e SHA1 2ba35adca8fb9c66a58eca61a15b21df6213f22e SHA256 9392b74e485e15f75a3e07a527547d4f6747eaf55ebce71ba0e863a9fd320b6e
+EBUILD qt-openvg-4.8.0-r1.ebuild 1311 RMD160 6e1404102e4f0cd4086d0692717de56ce977738f SHA1 a789169677d36e097c472a45c556285869b28574 SHA256 1f29d2d354e8d491e176468282dc7d0c3fb1f3ecbd200ff466625bdf443800e2
+MISC ChangeLog 272 RMD160 fb8b1368e31aef40a024a52641f351d3d0424f0b SHA1 0fa164d3ea7c79273872421ffacaeeb4c345d7e2 SHA256 16e279effe399515cf5fdc8c7bab0a52160d11eb42987e77c725624636df82ef
+MISC metadata.xml 451 RMD160 8290a3e1ef4bb02a45d3b0860c9dc21f2f24f979 SHA1 3841ee97cb44cef3c1a82b7629c422acdfc88a8b SHA256 6c2135bb2df8bbd48c397f37c4893a79f7448989e868e310ca11444ed37c71d5
diff --git a/x11-libs/qt-openvg/metadata.xml b/x11-libs/qt-openvg/metadata.xml
new file mode 100644
index 000000000000..573ce492e0e2
--- /dev/null
+++ b/x11-libs/qt-openvg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name='exceptions'>Build with support for exceptions</flag>
+ <flag name='qt3support'>Enable the Qt3Support libraries for Qt4</flag>
+ <flag name='c++0x'>Build Qt using the C++11 standard</flag>
+ <flag name='qpa'>Build a window system agnostic implementation of Qt</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-libs/qt-openvg/qt-openvg-4.8.0-r1.ebuild b/x11-libs/qt-openvg/qt-openvg-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..f09fb93d47fc
--- /dev/null
+++ b/x11-libs/qt-openvg/qt-openvg-4.8.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-openvg/qt-openvg-4.8.0-r1.ebuild,v 1.1 2012/01/30 10:25:11 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The OpenVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,debug=,egl,qpa=,qt3support=]
+ media-libs/mesa[openvg]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/openvg
+ src/plugins/graphicssystems/openvg"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenVG
+ src/corelib
+ src/gui
+ src/openvg
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="openvg"
+ QCONFIG_DEFINE="QT_OPENVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ gltype="desktop"
+
+ myconf="${myconf} -openvg -egl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ #touch the available graphics systems
+ mkdir -p "${D}/usr/share/qt4/graphicssystems/" ||
+ die "could not create ${D}/usr/share/qt4/graphicssystems/"
+ touch "${D}/usr/share/qt4/graphicssystems/openvg" ||
+ die "could not touch ${D}/usr/share/qt4/graphicssystems/openvg"
+}