summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-09-09 01:08:23 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-09-09 01:08:23 +0000
commit7674af566f901f2c392759490a40a1c989adfda4 (patch)
tree68cf0a809fc893af6e63fa824145e9dfd82cc0a0 /x11-libs
parentMarked ~ppc for bug #187626. (diff)
downloadgentoo-2-7674af566f901f2c392759490a40a1c989adfda4.tar.gz
gentoo-2-7674af566f901f2c392759490a40a1c989adfda4.tar.bz2
gentoo-2-7674af566f901f2c392759490a40a1c989adfda4.zip
Update collision patch to handle wxrc.
(Portage version: 2.1.3.9)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.6.4-collision.patch17
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild5
3 files changed, 22 insertions, 6 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index d3684debcd8b..813c36d7bba5 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.147 2007/09/02 00:40:08 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.148 2007/09/09 01:08:22 dirtyepic Exp $
+
+ 09 Sep 2007; Ryan Hill <dirtyepic@gentoo.org>
+ files/wxGTK-2.6.4-collision.patch, wxGTK-2.6.4.0.ebuild:
+ Update collision patch to handle wxrc.
02 Sep 2007; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.6.4.0.ebuild:
Re-keyword.
diff --git a/x11-libs/wxGTK/files/wxGTK-2.6.4-collision.patch b/x11-libs/wxGTK/files/wxGTK-2.6.4-collision.patch
index a93f378955c7..1d4e151ea007 100644
--- a/x11-libs/wxGTK/files/wxGTK-2.6.4-collision.patch
+++ b/x11-libs/wxGTK/files/wxGTK-2.6.4-collision.patch
@@ -1,6 +1,6 @@
diff -Naur wxPython-src-2.6.4.0-orig/Makefile.in wxPython-src-2.6.4.0/Makefile.in
---- wxPython-src-2.6.4.0-orig/Makefile.in 2007-07-29 11:47:53.000000000 -0600
-+++ wxPython-src-2.6.4.0/Makefile.in 2007-07-29 12:35:22.000000000 -0600
+--- wxPython-src-2.6.4.0-orig/Makefile.in 2007-09-08 18:58:36.000000000 -0600
++++ wxPython-src-2.6.4.0/Makefile.in 2007-09-08 19:00:36.000000000 -0600
@@ -26,6 +26,7 @@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
@@ -44,7 +44,7 @@ diff -Naur wxPython-src-2.6.4.0-orig/Makefile.in wxPython-src-2.6.4.0/Makefile.i
diff -Naur wxPython-src-2.6.4.0-orig/src/common/intl.cpp wxPython-src-2.6.4.0/src/common/intl.cpp
--- wxPython-src-2.6.4.0-orig/src/common/intl.cpp 2007-03-20 09:25:41.000000000 -0600
-+++ wxPython-src-2.6.4.0/src/common/intl.cpp 2007-07-29 12:29:45.000000000 -0600
++++ wxPython-src-2.6.4.0/src/common/intl.cpp 2007-09-08 19:00:36.000000000 -0600
@@ -1452,6 +1452,8 @@
m_initialized = false;
}
@@ -63,3 +63,14 @@ diff -Naur wxPython-src-2.6.4.0-orig/src/common/intl.cpp wxPython-src-2.6.4.0/sr
// there may be a catalog with toolkit specific overrides, it is not
// an error if this does not exist
+diff -Naur wxPython-src-2.6.4.0-orig/utils/wxrc/Makefile.in wxPython-src-2.6.4.0/utils/wxrc/Makefile.in
+--- wxPython-src-2.6.4.0-orig/utils/wxrc/Makefile.in 2007-09-08 18:58:36.000000000 -0600
++++ wxPython-src-2.6.4.0/utils/wxrc/Makefile.in 2007-09-08 19:01:46.000000000 -0600
+@@ -125,7 +125,6 @@
+ @COND_USE_XRC_1@ $(INSTALL_DIR) $(DESTDIR)$(bindir)
+ @COND_USE_XRC_1@ $(INSTALL_PROGRAM) wxrc$(EXEEXT) $(DESTDIR)$(bindir)
+ @COND_USE_XRC_1@ mv -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT) $(DESTDIR)$(bindir)/wxrc-$(WX_RELEASE)
+-@COND_USE_XRC_1@ (cd $(DESTDIR)$(bindir) && $(LN_S) wxrc-$(WX_RELEASE) wxrc$(EXEEXT))
+
+ @COND_USE_XRC_1@uninstall_wxrc:
+ @COND_USE_XRC_1@ rm -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT)
diff --git a/x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild b/x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild
index f0b1aeb6e3d1..82d35ab1981b 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild,v 1.2 2007/09/02 00:40:08 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0.ebuild,v 1.3 2007/09/09 01:08:22 dirtyepic Exp $
inherit eutils versionator flag-o-matic
@@ -35,7 +35,8 @@ DEPEND="
)"
SLOT="2.6"
-LICENSE="wxWinLL-3 GPL-2
+LICENSE="wxWinLL-3
+ GPL-2
odbc? ( LGPL-2 )
doc? ( wxWinFDL-3 )"