summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-29 11:10:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-29 11:10:21 +0000
commit7845dc911ca0fa3ef2caa2c064620681fa376578 (patch)
tree1d239f31837d0f7ec6f5b25879b32b1bd381bb81 /x11-libs
parentConvert to ruby-ng. Added ~amd64. (diff)
downloadgentoo-2-7845dc911ca0fa3ef2caa2c064620681fa376578.tar.gz
gentoo-2-7845dc911ca0fa3ef2caa2c064620681fa376578.tar.bz2
gentoo-2-7845dc911ca0fa3ef2caa2c064620681fa376578.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm/ChangeLog7
-rw-r--r--x11-libs/libfm/libfm-0.1.12.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index d27e5fca2c7a..3d24d9390330 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.6 2010/05/02 20:46:39 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.7 2010/05/29 11:10:21 hwoarang Exp $
+
+*libfm-0.1.12 (29 May 2010)
+
+ 29 May 2010; Markos Chandras <hwoarang@gentoo.org> +libfm-0.1.12.ebuild:
+ Version bump
*libfm-0.1.11 (02 May 2010)
diff --git a/x11-libs/libfm/libfm-0.1.12.ebuild b/x11-libs/libfm/libfm-0.1.12.ebuild
new file mode 100644
index 000000000000..96e7712148b8
--- /dev/null
+++ b/x11-libs/libfm/libfm-0.1.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-0.1.12.ebuild,v 1.1 2010/05/29 11:10:21 hwoarang Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcmanfm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug demo"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ >=lxde-base/menu-cache-0.3.2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ strip-linguas -i "${S}/po"
+ econf --sysconfdir=/etc $(use_enable debug) $(use_enable demo)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS TODO || die
+}