summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-09-28 22:43:13 +0000
committerZac Medico <zmedico@gentoo.org>2009-09-28 22:43:13 +0000
commita8bc2131ce7fdf14ce4b21fa82acb34ed29e2728 (patch)
treee3a3866ac2c056db05035179c9448e1b2b2d6a69 /x11-libs
parentAdd ebuild to install just the old ABI lib. (diff)
downloadgentoo-2-a8bc2131ce7fdf14ce4b21fa82acb34ed29e2728.tar.gz
gentoo-2-a8bc2131ce7fdf14ce4b21fa82acb34ed29e2728.tar.bz2
gentoo-2-a8bc2131ce7fdf14ce4b21fa82acb34ed29e2728.zip
Install missing header files.
(Portage version: 2.2_rc42_p14455/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libdrm-poulsbo/ChangeLog8
-rw-r--r--x11-libs/libdrm-poulsbo/libdrm-poulsbo-2.3.0_p9-r1.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-libs/libdrm-poulsbo/ChangeLog b/x11-libs/libdrm-poulsbo/ChangeLog
index 1a7b60f07a8d..7ee77cb7cc83 100644
--- a/x11-libs/libdrm-poulsbo/ChangeLog
+++ b/x11-libs/libdrm-poulsbo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libdrm-poulsbo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdrm-poulsbo/ChangeLog,v 1.2 2009/09/28 19:39:04 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdrm-poulsbo/ChangeLog,v 1.3 2009/09/28 22:43:13 zmedico Exp $
+
+*libdrm-poulsbo-2.3.0_p9-r1 (28 Sep 2009)
+
+ 28 Sep 2009; Zac Medico <zmedico@gentoo.org>
+ +libdrm-poulsbo-2.3.0_p9-r1.ebuild:
+ Install missing header files.
28 Sep 2009; Zac Medico <zmedico@gentoo.org>
libdrm-poulsbo-2.3.0_p9.ebuild:
diff --git a/x11-libs/libdrm-poulsbo/libdrm-poulsbo-2.3.0_p9-r1.ebuild b/x11-libs/libdrm-poulsbo/libdrm-poulsbo-2.3.0_p9-r1.ebuild
new file mode 100644
index 000000000000..3eb1baad52da
--- /dev/null
+++ b/x11-libs/libdrm-poulsbo/libdrm-poulsbo-2.3.0_p9-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdrm-poulsbo/libdrm-poulsbo-2.3.0_p9-r1.ebuild,v 1.1 2009/09/28 22:43:13 zmedico Exp $
+
+EAPI="2"
+
+WANT_AUTOMAKE="1.9"
+
+inherit rpm autotools
+
+DESCRIPTION="libdrm for the intel gma500 (poulsbo)"
+HOMEPAGE="http://www.happyassassin.net/2009/05/13/native-poulsbo-gma-500-graphics-driver-for-fedora-10/"
+SRC_URI="http://adamwill.fedorapeople.org/poulsbo/src/libdrm-poulsbo-2.3.0-9.fc11.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=x11-libs/libdrm-2.3"
+
+S=${WORKDIR}/libdrm-2.3.0
+
+src_prepare() {
+ epatch "${WORKDIR}/${PN}_configure_debian.patch"
+ epatch "${WORKDIR}/${PN}_headers_debian.patch"
+ epatch "${WORKDIR}/${PN}-relocate_headers.patch"
+
+ mv "${WORKDIR}/*.h" "${S}/shared-core"
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/lib/psb -includedir=/usr/include/psb
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ insinto /usr/include/psb/drm
+ doins "${WORKDIR}"/*.h
+ dodir /usr/lib/pkgconfig
+ mv "${D}/usr/lib/psb/pkgconfig/libdrm.pc" "${D}/usr/lib/pkgconfig/libdrm-poulsbo.pc"
+ dodir /etc/env.d
+ echo LDPATH=/usr/lib/psb > ${D}/etc/env.d/02psb
+}