summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 12:00:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 12:00:23 +0000
commitb0040988c1a411ddbc24e8598e1a4189f4e59d9d (patch)
tree81ecb00ec8cb30b52a66c668032354bc1864f5b0 /x11-libs
parentadded ~sparc as per #301446 (diff)
downloadgentoo-2-b0040988c1a411ddbc24e8598e1a4189f4e59d9d.tar.gz
gentoo-2-b0040988c1a411ddbc24e8598e1a4189f4e59d9d.tar.bz2
gentoo-2-b0040988c1a411ddbc24e8598e1a4189f4e59d9d.zip
Fix building with libpng14.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/openmotif-2.3.2-libpng14.patch13
-rw-r--r--x11-libs/openmotif/openmotif-2.3.2-r2.ebuild5
3 files changed, 22 insertions, 2 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index bb1132846585..2064c58a49e6 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.227 2010/02/11 10:22:56 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.228 2010/03/08 12:00:22 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ openmotif-2.3.2-r2.ebuild, +files/openmotif-2.3.2-libpng14.patch:
+ Fix building with libpng14.
*openmotif-2.3.2-r2 (11 Feb 2010)
diff --git a/x11-libs/openmotif/files/openmotif-2.3.2-libpng14.patch b/x11-libs/openmotif/files/openmotif-2.3.2-libpng14.patch
new file mode 100644
index 000000000000..5b817719c7dc
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.3.2-libpng14.patch
@@ -0,0 +1,13 @@
+http://www.mail-archive.com/pld-cvs-commit@lists.pld-linux.org/msg207680.html
+
+--- lib/Xm/Png.c
++++ lib/Xm/Png.c
+@@ -144,7 +144,7 @@
+ png_bytepp row_pointers = NULL;
+
+ fread(sig, 1, 8, infile);
+- if (!png_check_sig(sig, 8))
++ if (png_sig_cmp(sig, 0, 8))
+ return 1; /* bad signature */
+
+ png_ptr =
diff --git a/x11-libs/openmotif/openmotif-2.3.2-r2.ebuild b/x11-libs/openmotif/openmotif-2.3.2-r2.ebuild
index a450fe66210c..a0355556a25c 100644
--- a/x11-libs/openmotif/openmotif-2.3.2-r2.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.2-r2.ebuild,v 1.2 2010/02/11 22:04:07 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.2-r2.ebuild,v 1.3 2010/03/08 12:00:22 ssuominen Exp $
EAPI=3
@@ -95,6 +95,9 @@ src_prepare() {
# add X.Org vendor string to aliases for virtual bindings
echo -e '"The X.Org Foundation"\t\t\t\t\tpc' >>bindings/xmbind.alias
+ has_version ">=media-libs/libpng-1.4" && epatch \
+ "${FILESDIR}"/${P}-libpng14.patch
+
AT_M4DIR=. eautoreconf
}