summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-04-02 21:18:49 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-04-02 21:18:49 +0000
commitb216ff47bac1a1c45cd5f91a4b1a2c89a49c2dca (patch)
tree7e8c4fb94c395c6c33a7dd1f7b74ae9a10e4b21a /x11-libs
parentImport Debian patchset. Build both shared and static libs. (diff)
downloadgentoo-2-b216ff47bac1a1c45cd5f91a4b1a2c89a49c2dca.tar.gz
gentoo-2-b216ff47bac1a1c45cd5f91a4b1a2c89a49c2dca.tar.bz2
gentoo-2-b216ff47bac1a1c45cd5f91a4b1a2c89a49c2dca.zip
Build fix for unixODBC-2.2.14 (bug #310923 by Martin von Gagern).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.8.10.1-odbc-defines.patch39
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild3
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild3
4 files changed, 48 insertions, 3 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index c6b3dcbc9e35..db6f13218a17 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.249 2010/03/21 14:16:42 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.250 2010/04/02 21:18:49 dirtyepic Exp $
+
+ 02 Apr 2010; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.6.4.0-r6.ebuild,
+ wxGTK-2.8.10.1-r5.ebuild, +files/wxGTK-2.8.10.1-odbc-defines.patch:
+ Build fix for unixODBC-2.2.14 (bug #310923 by Martin von Gagern).
21 Mar 2010; Brent Baude <ranger@gentoo.org> wxGTK-2.6.4.0-r6.ebuild,
wxGTK-2.8.10.1-r5.ebuild:
diff --git a/x11-libs/wxGTK/files/wxGTK-2.8.10.1-odbc-defines.patch b/x11-libs/wxGTK/files/wxGTK-2.8.10.1-odbc-defines.patch
new file mode 100644
index 000000000000..3636b64f976a
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.8.10.1-odbc-defines.patch
@@ -0,0 +1,39 @@
+unixODBC 2.2.14 defines SQLLEN and SQLULEN using the compiler typedef
+declaration instead of preprocessor #define macro definition. This breaks
+the preprocessor checks in this include file.cpp, causing the source to fall
+back to older types instead, leading to compile time errors like this:
+
+db.cpp:1636: error: cannot convert ‘SQLINTEGER*’ to ‘SQLLEN*’ for argument ‘6’ to
+‘SQLRETURN SQLGetData(void*, SQLUSMALLINT, SQLSMALLINT, void*, SQLLEN, SQLLEN*)’
+...
+dbtable.cpp:592: error: cannot convert ‘SQLUINTEGER*’ to ‘SQLULEN*’ for argument ‘4’ to
+‘SQLRETURN SQLExtendedFetch(void*, SQLUSMALLINT, SQLLEN, SQLULEN*, SQLUSMALLINT*)’
+...
+
+This change hard-wires the new names, breaking compatibility with ancient
+(pre 2001) unixODBC versions. This change may break other ODBC implementations
+but in Gentoo only unixODBC is supported.
+
+References:
+http://bugs.gentoo.org/310923
+
+2010-03-23 Martin von Gagern
+
+--- wxPython-src-2.6.4.0.orig/include/wx/db.h
++++ wxPython-src-2.6.4.0/include/wx/db.h
+@@ -134,15 +134,6 @@ enum enumDummy {enumDum1};
+ #endif
+ #endif
+
+-#ifndef _WIN64
+-#ifndef SQLLEN
+-#define SQLLEN SQLINTEGER
+-#endif
+-#ifndef SQLULEN
+-#define SQLULEN SQLUINTEGER
+-#endif
+-#endif
+-
+ const int wxDB_PATH_MAX = 254;
+
+ extern WXDLLIMPEXP_DATA_ODBC(wxChar const *) SQL_LOG_FILENAME;
diff --git a/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild b/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
index 8af6b2442f2a..f64f760fd79c 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild,v 1.6 2010/03/21 14:16:42 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild,v 1.7 2010/04/02 21:18:49 dirtyepic Exp $
inherit eutils versionator flag-o-matic
@@ -62,6 +62,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.6.3-unicode-odbc.patch
epatch "${FILESDIR}"/${BASE_P}-collision.patch
epatch "${FILESDIR}"/${BASE_P}-mmedia.patch # Bug #174874
+ epatch "${FILESDIR}"/${PN}-2.8.10.1-odbc-defines.patch # Bug #310923
# Patches Specific to this version
diff --git a/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild b/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
index 3ba9cac71777..03a326fcb5f5 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild,v 1.6 2010/03/21 14:16:42 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild,v 1.7 2010/04/02 21:18:49 dirtyepic Exp $
EAPI="2"
@@ -60,6 +60,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.6.3-unicode-odbc.patch
epatch "${FILESDIR}"/${PN}-2.8.10-collision.patch
epatch "${FILESDIR}"/${PN}-2.8.7-mmedia.patch # Bug #174874
+ epatch "${FILESDIR}"/${PN}-2.8.10.1-odbc-defines.patch # Bug #310923
# this version only:
epatch "${FILESDIR}"/${P}-CVE-2009-2369.patch # Bug #277722
epatch "${FILESDIR}"/${P}-gsocket.patch # Bug #278778