summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2009-12-23 12:50:15 +0000
committerDror Levin <spatz@gentoo.org>2009-12-23 12:50:15 +0000
commitb32d40370d2f3be492e310e10d7769d5b771fca2 (patch)
treed05fd77e87de3bfa8e912fa3331a79a71701b020 /x11-libs
parentAdd jabber use-flag, drop ~hppa keyword due to unsatisfied deps. (#295361) (diff)
downloadgentoo-2-b32d40370d2f3be492e310e10d7769d5b771fca2.tar.gz
gentoo-2-b32d40370d2f3be492e310e10d7769d5b771fca2.tar.bz2
gentoo-2-b32d40370d2f3be492e310e10d7769d5b771fca2.zip
Apply patch to fix crashing with some Hebrew text, bug 297773.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-core/ChangeLog6
-rw-r--r--x11-libs/qt-core/files/qt-core-4.6.0-hebrew.patch69
-rw-r--r--x11-libs/qt-core/qt-core-4.6.0.ebuild3
3 files changed, 76 insertions, 2 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index a8bd800af802..87f461790fe1 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.81 2009/12/03 17:22:07 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.82 2009/12/23 12:50:15 spatz Exp $
+
+ 23 Dec 2009; Dror Levin <spatz@gentoo.org> qt-core-4.6.0.ebuild,
+ +files/qt-core-4.6.0-hebrew.patch:
+ Apply patch to fix crashing with some Hebrew text, bug 297773.
03 Dec 2009; Alex Alexander <wired@gentoo.org>
+files/qt-4.6-nolibx11.diff, qt-core-4.6.0.ebuild:
diff --git a/x11-libs/qt-core/files/qt-core-4.6.0-hebrew.patch b/x11-libs/qt-core/files/qt-core-4.6.0-hebrew.patch
new file mode 100644
index 000000000000..5275fbbf4561
--- /dev/null
+++ b/x11-libs/qt-core/files/qt-core-4.6.0-hebrew.patch
@@ -0,0 +1,69 @@
+From ddf34f39efcbe679f1a8216df58da0c61e98ec79 Mon Sep 17 00:00:00 2001
+From: Lars Knoll <lars.knoll@nokia.com>
+Date: Mon, 21 Dec 2009 14:30:40 +0100
+Subject: [PATCH] update harfbuzz to 2b78f0d78ad3075fd1657d1260b31219e1a5155
+
+Fix a regression in Hebrew text rendering that got introduced
+in Harfbuzz.
+Fix some uninitialized variables.
+
+Task-number: http://bugreports.qt.nokia.com/browse/QTBUG-6436
+Reviewed-by: Simon Hausmann
+---
+ src/3rdparty/harfbuzz/src/harfbuzz-hebrew.c | 4 +---
+ src/3rdparty/harfbuzz/src/harfbuzz-shaper.cpp | 3 +++
+ 2 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/src/3rdparty/harfbuzz/src/harfbuzz-hebrew.c b/src/3rdparty/harfbuzz/src/harfbuzz-hebrew.c
+index 2bda386..67029be 100644
+--- a/src/3rdparty/harfbuzz/src/harfbuzz-hebrew.c
++++ b/src/3rdparty/harfbuzz/src/harfbuzz-hebrew.c
+@@ -56,8 +56,6 @@ HB_Bool HB_HebrewShape(HB_ShaperItem *shaper_item)
+
+ assert(shaper_item->item.script == HB_Script_Hebrew);
+
+- HB_HeuristicSetGlyphAttributes(shaper_item);
+-
+ #ifndef NO_OPENTYPE
+ if (HB_SelectScript(shaper_item, hebrew_features)) {
+
+@@ -65,7 +63,7 @@ HB_Bool HB_HebrewShape(HB_ShaperItem *shaper_item)
+ if (!HB_ConvertStringToGlyphIndices(shaper_item))
+ return FALSE;
+
+-
++ HB_HeuristicSetGlyphAttributes(shaper_item);
+ HB_OpenTypeShape(shaper_item, /*properties*/0);
+ return HB_OpenTypePosition(shaper_item, availableGlyphs, /*doLogClusters*/TRUE);
+ }
+diff --git a/src/3rdparty/harfbuzz/src/harfbuzz-shaper.cpp b/src/3rdparty/harfbuzz/src/harfbuzz-shaper.cpp
+index bfb03ab..bfc7bd4 100644
+--- a/src/3rdparty/harfbuzz/src/harfbuzz-shaper.cpp
++++ b/src/3rdparty/harfbuzz/src/harfbuzz-shaper.cpp
+@@ -980,6 +980,7 @@ HB_Face HB_NewFace(void *font, HB_GetFontTableFunc tableFunc)
+ HB_Stream gdefStream;
+
+ gdefStream = getTableStream(font, tableFunc, TTAG_GDEF);
++ error = HB_Err_Not_Covered;
+ if (!gdefStream || (error = HB_Load_GDEF_Table(gdefStream, &face->gdef))) {
+ //DEBUG("error loading gdef table: %d", error);
+ face->gdef = 0;
+@@ -987,6 +988,7 @@ HB_Face HB_NewFace(void *font, HB_GetFontTableFunc tableFunc)
+
+ //DEBUG() << "trying to load gsub table";
+ stream = getTableStream(font, tableFunc, TTAG_GSUB);
++ error = HB_Err_Not_Covered;
+ if (!stream || (error = HB_Load_GSUB_Table(stream, &face->gsub, face->gdef, gdefStream))) {
+ face->gsub = 0;
+ if (error != HB_Err_Not_Covered) {
+@@ -998,6 +1000,7 @@ HB_Face HB_NewFace(void *font, HB_GetFontTableFunc tableFunc)
+ _hb_close_stream(stream);
+
+ stream = getTableStream(font, tableFunc, TTAG_GPOS);
++ error = HB_Err_Not_Covered;
+ if (!stream || (error = HB_Load_GPOS_Table(stream, &face->gpos, face->gdef, gdefStream))) {
+ face->gpos = 0;
+ DEBUG("error loading gpos table: %d", error);
+--
+1.6.6.rc4
+
diff --git a/x11-libs/qt-core/qt-core-4.6.0.ebuild b/x11-libs/qt-core/qt-core-4.6.0.ebuild
index 1ca7628fc7b1..60b1235bcd5d 100644
--- a/x11-libs/qt-core/qt-core-4.6.0.ebuild
+++ b/x11-libs/qt-core/qt-core-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.6.0.ebuild,v 1.2 2009/12/03 17:22:07 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.6.0.ebuild,v 1.3 2009/12/23 12:50:15 spatz Exp $
EAPI="2"
inherit qt4-build
@@ -54,6 +54,7 @@ translations"
PATCHES=(
"${FILESDIR}/qt-4.6-nolibx11.diff"
+ "${FILESDIR}/${P}-hebrew.patch"
)
pkg_setup() {