summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-10-28 11:57:46 +0000
committerMart Raudsepp <leio@gentoo.org>2008-10-28 11:57:46 +0000
commitbccee76f2708037617ab9b6f1ea70dc20677c1c1 (patch)
tree7311e4617c3ff0417f3ac866b07bc9255ebba9fe /x11-libs
parentUse python_need_rebuild. (diff)
downloadgentoo-2-bccee76f2708037617ab9b6f1ea70dc20677c1c1.tar.gz
gentoo-2-bccee76f2708037617ab9b6f1ea70dc20677c1c1.tar.bz2
gentoo-2-bccee76f2708037617ab9b6f1ea70dc20677c1c1.zip
Fix highlighting on activity, bug 242636
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/files/vte-0.17.4-fix-selecting-on-activity.patch41
-rw-r--r--x11-libs/vte/vte-0.17.4-r1.ebuild52
3 files changed, 100 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 0d0405fa704e..e3c3bf023882 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.210 2008/10/10 14:08:21 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.211 2008/10/28 11:57:46 leio Exp $
+
+*vte-0.17.4-r1 (28 Oct 2008)
+
+ 28 Oct 2008; Mart Raudsepp <leio@gentoo.org>
+ +files/vte-0.17.4-fix-selecting-on-activity.patch, +vte-0.17.4-r1.ebuild:
+ Fix highlighting on activity, bug 242636
*vte-0.17.4 (10 Oct 2008)
diff --git a/x11-libs/vte/files/vte-0.17.4-fix-selecting-on-activity.patch b/x11-libs/vte/files/vte-0.17.4-fix-selecting-on-activity.patch
new file mode 100644
index 000000000000..5cf9b91acfd6
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.17.4-fix-selecting-on-activity.patch
@@ -0,0 +1,41 @@
+Upstream revision 2134 with useless whitespace change hunks removed:
+
+2008-10-23 Chris Wilson
+
+Bug 557375 – >=vte-0.16.14 breaks highlighting on activity
+
+* src/vte.c (vte_terminal_deselect_all),
+(vte_terminal_extend_selection):
+After the user modifies the selection, copy it to PRIMARY and store
+it on the terminal. This ensures that after a screen redraw, we
+compare the contents of the selected region with the current
+selection, instead of stale data.
+
+--- trunk/src/vte.c 2008/10/23 09:15:37 2133
++++ trunk/src/vte.c 2008/10/23 09:43:21 2134
+@@ -1018,10 +1018,16 @@
+ {
+ if (terminal->pvt->has_selection) {
+ gint sx, sy, ex, ey;
+- terminal->pvt->has_selection = FALSE;
++
+ _vte_debug_print(VTE_DEBUG_SELECTION,
+ "Deselecting all text.\n");
++
++ terminal->pvt->has_selection = FALSE;
++ g_free (terminal->pvt->selection);
++ terminal->pvt->selection = NULL;
++
+ vte_terminal_emit_selection_changed(terminal);
++
+ sx = terminal->pvt->selection_start.x;
+ sy = terminal->pvt->selection_start.y;
+ ex = terminal->pvt->selection_end.x;
+@@ -6510,6 +6514,7 @@
+ terminal->pvt->selection_start.y,
+ terminal->pvt->selection_end.x,
+ terminal->pvt->selection_end.y);
++ vte_terminal_copy_primary(terminal);
+ vte_terminal_emit_selection_changed(terminal);
+ }
+
diff --git a/x11-libs/vte/vte-0.17.4-r1.ebuild b/x11-libs/vte/vte-0.17.4-r1.ebuild
new file mode 100644
index 000000000000..fb3fd0839cd3
--- /dev/null
+++ b/x11-libs/vte/vte-0.17.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.17.4-r1.ebuild,v 1.1 2008/10/28 11:57:46 leio Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable python)
+ $(use_with opengl glX)
+ --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}/${P}-fix-selecting-on-activity.patch"
+}