summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-09-15 14:43:08 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-09-15 14:43:08 +0000
commitdcefde9e61a52e24aec99bbd44a77019c511a797 (patch)
treec0732a6a3e31be55d4b51e561f65ba1495b29c94 /x11-libs
parentmedia-plugins/vdr-prefermenu masked for removal on ~15/Oct/2013, Bug #420883 ... (diff)
downloadgentoo-2-dcefde9e61a52e24aec99bbd44a77019c511a797.tar.gz
gentoo-2-dcefde9e61a52e24aec99bbd44a77019c511a797.tar.bz2
gentoo-2-dcefde9e61a52e24aec99bbd44a77019c511a797.zip
Version bump, bug #484990.
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/glamor/ChangeLog8
-rw-r--r--x11-libs/glamor/glamor-0.5.1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/glamor/ChangeLog b/x11-libs/glamor/ChangeLog
index 7550ec75670f..71eafb2d7017 100644
--- a/x11-libs/glamor/ChangeLog
+++ b/x11-libs/glamor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/glamor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.15 2013/03/12 16:43:56 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.16 2013/09/15 14:43:08 chithanh Exp $
+
+*glamor-0.5.1 (15 Sep 2013)
+
+ 15 Sep 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +glamor-0.5.1.ebuild:
+ Version bump, bug #484990.
*glamor-0.5-r1 (12 Mar 2013)
diff --git a/x11-libs/glamor/glamor-0.5.1.ebuild b/x11-libs/glamor/glamor-0.5.1.ebuild
new file mode 100644
index 000000000000..4be4e048aad7
--- /dev/null
+++ b/x11-libs/glamor/glamor-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.1.ebuild,v 1.1 2013/09/15 14:43:08 chithanh Exp $
+
+EAPI=5
+
+XORG_DRI=always
+XORG_EAUTORECONF=yes
+XORG_MODULE=driver/
+XORG_MODULE_REBUILD=yes
+S=${WORKDIR}/${PN}-egl-${PV}
+
+inherit xorg-2
+
+DESCRIPTION="OpenGL based 2D rendering acceleration library"
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gles"
+
+RDEPEND=">=x11-base/xorg-server-1.10
+ media-libs/mesa[egl,gbm]
+ gles? (
+ || ( media-libs/mesa[gles2] media-libs/mesa[gles] )
+ )
+ >=x11-libs/pixman-0.21.8"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable gles glamor-gles2)
+ )
+ xorg-2_src_configure
+}
+
+src_prepare() {
+ sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
+ xorg-2_src_prepare
+}