summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-12 11:09:11 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-12 11:09:11 +0000
commitde1fa42cb57660dfa179b1ec2a0459492b6aa4ca (patch)
tree0a1895f569c20f3b88f4e114b8ade8b0ab75019d /x11-libs
parentversion bump (diff)
downloadgentoo-2-de1fa42cb57660dfa179b1ec2a0459492b6aa4ca.tar.gz
gentoo-2-de1fa42cb57660dfa179b1ec2a0459492b6aa4ca.tar.bz2
gentoo-2-de1fa42cb57660dfa179b1ec2a0459492b6aa4ca.zip
Corrected slotting for png and tiff, resorted ebuild to fit common sense order, removed unnessesary die
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog8
-rw-r--r--x11-libs/wxGTK/metadata.xml6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild16
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild15
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild15
-rw-r--r--x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild15
-rw-r--r--x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild13
7 files changed, 54 insertions, 34 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index d0527d6c5132..f1afea0e2cc1 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.272 2011/10/25 04:06:33 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.273 2011/11/12 11:09:11 jlec Exp $
+
+ 12 Nov 2011; Justin Lecher <jlec@gentoo.org> wxGTK-2.6.4.0-r6.ebuild,
+ wxGTK-2.8.10.1-r5.ebuild, wxGTK-2.8.11.0.ebuild, wxGTK-2.8.12.0.ebuild,
+ wxGTK-2.9.1.1.ebuild, metadata.xml:
+ Corrected slotting for png and tiff, resorted ebuild to fit common sense
+ order, removed unnessesary die
25 Oct 2011; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.9.1.1.ebuild:
Apply libpng-1.5 patch to 2.9 as well.
diff --git a/x11-libs/wxGTK/metadata.xml b/x11-libs/wxGTK/metadata.xml
index 6cc9203f7644..a2a438661a2f 100644
--- a/x11-libs/wxGTK/metadata.xml
+++ b/x11-libs/wxGTK/metadata.xml
@@ -7,14 +7,14 @@
<description>All modifications to this package must be approved by the wxwidgets herd.</description>
</maintainer>
<use>
- <flag name='gstreamer'>
+ <flag name="gstreamer">
Enable the wxMediaCtrl class for playing audio and video through
gstreamer.
</flag>
- <flag name='gnome'>
+ <flag name="gnome">
Use <pkg>gnome-base/libgnomeprintui</pkg> for printing tasks.
</flag>
- <flag name='sdl'>
+ <flag name="sdl">
Use Simple Directmedia Layer (<pkg>media-libs/libsdl</pkg>) for
audio.
</flag>
diff --git a/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild b/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
index c783fa6c8747..d6f41293d2cc 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild,v 1.12 2011/09/15 19:24:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.4.0-r6.ebuild,v 1.13 2011/11/12 11:09:11 jlec Exp $
EAPI=1
inherit eutils versionator flag-o-matic
@@ -24,14 +24,17 @@ RDEPEND="
odbc? ( dev-db/unixODBC )
sdl? ( media-libs/libsdl )
X? (
- x11-libs/gtk+:2
- dev-libs/glib:2
+ >=dev-libs/glib-2.22:2
+ media-libs/libpng:0
+ sys-libs/zlib
virtual/jpeg
- media-libs/tiff
+ >=x11-libs/gtk+-2.18:2
+ media-libs/tiff:0
x11-libs/libSM
x11-libs/libXinerama
x11-libs/libXxf86vm
- gnome? ( gnome-base/libgnomeprintui )
+ x11-libs/pango
+ gnome? ( gnome-base/libgnomeprintui )
opengl? ( virtual/opengl )
)"
@@ -201,8 +204,7 @@ build_wx() {
ECONF_SOURCE="${S}" econf \
${myconf} \
- ${build_wx_conf} \
- || die "Failed to configure $1."
+ ${build_wx_conf}
emake || die "Failed to make $1."
diff --git a/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild b/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
index 5260b58d7f49..d3935b381dae 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild,v 1.11 2011/02/27 14:32:40 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.10.1-r5.ebuild,v 1.12 2011/11/12 11:09:11 jlec Exp $
EAPI="2"
inherit eutils versionator flag-o-matic
-DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="http://wxwidgets.org/"
BASE_PV="$(get_version_component_range 1-3)"
@@ -24,13 +24,16 @@ RDEPEND="
odbc? ( dev-db/unixODBC )
sdl? ( media-libs/libsdl )
X? (
- >=x11-libs/gtk+-2.4:2
- >=dev-libs/glib-2.4:2
+ >=dev-libs/glib-2.22:2
+ media-libs/libpng:0
+ sys-libs/zlib
virtual/jpeg
- media-libs/tiff
+ >=x11-libs/gtk+-2.18:2
+ media-libs/tiff:0
x11-libs/libSM
x11-libs/libXinerama
x11-libs/libXxf86vm
+ x11-libs/pango
gnome? ( gnome-base/libgnomeprintui:2.2 )
gstreamer? (
gnome-base/gconf:2
@@ -116,7 +119,7 @@ src_configure() {
mkdir "${S}"/wxgtk_build
cd "${S}"/wxgtk_build
- ECONF_SOURCE="${S}" econf ${myconf} || die "configure failed."
+ ECONF_SOURCE="${S}" econf ${myconf}
}
src_compile() {
diff --git a/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild b/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild
index 995d48a9b821..3432a11bd35f 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild,v 1.12 2011/07/16 09:32:34 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.11.0.ebuild,v 1.13 2011/11/12 11:09:11 jlec Exp $
EAPI="2"
inherit eutils versionator flag-o-matic
-DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="http://wxwidgets.org/"
BASE_PV="$(get_version_component_range 1-3)"
@@ -24,18 +24,21 @@ RDEPEND="
odbc? ( dev-db/unixODBC )
sdl? ( media-libs/libsdl )
X? (
- >=x11-libs/gtk+-2.4:2
- >=dev-libs/glib-2.4:2
+ >=dev-libs/glib-2.22:2
+ media-libs/libpng:0
+ sys-libs/zlib
virtual/jpeg
+ >=x11-libs/gtk+-2.18:2
x11-libs/libSM
x11-libs/libXinerama
x11-libs/libXxf86vm
+ x11-libs/pango
gnome? ( gnome-base/libgnomeprintui:2.2 )
gstreamer? (
gnome-base/gconf:2
>=media-libs/gstreamer-0.10 )
opengl? ( virtual/opengl )
- tiff? ( media-libs/tiff )
+ tiff? ( media-libs/tiff:0 )
)"
DEPEND="${RDEPEND}
@@ -107,7 +110,7 @@ src_configure() {
mkdir "${S}"/wxgtk_build
cd "${S}"/wxgtk_build
- ECONF_SOURCE="${S}" econf ${myconf} || die "configure failed."
+ ECONF_SOURCE="${S}" econf ${myconf}
}
src_compile() {
diff --git a/x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild b/x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild
index 8af62d97ac14..2d9039f86f5a 100644
--- a/x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild,v 1.2 2011/10/09 10:27:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.12.0.ebuild,v 1.3 2011/11/12 11:09:11 jlec Exp $
EAPI="2"
inherit eutils versionator flag-o-matic
-DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="http://wxwidgets.org/"
BASE_PV="$(get_version_component_range 1-3)"
@@ -24,19 +24,22 @@ RDEPEND="
odbc? ( dev-db/unixODBC )
sdl? ( media-libs/libsdl )
X? (
- >=x11-libs/gtk+-2.4:2
- >=dev-libs/glib-2.4:2
+ >=dev-libs/glib-2.22:2
+ media-libs/libpng:0
+ sys-libs/zlib
virtual/jpeg
+ >=x11-libs/gtk+-2.18:2
x11-libs/libSM
x11-libs/libXinerama
x11-libs/libXxf86vm
+ x11-libs/pango
gnome? ( gnome-base/libgnomeprintui:2.2 )
gstreamer? (
gnome-base/gconf:2
>=media-libs/gstreamer-0.10
>=media-libs/gst-plugins-base-0.10 )
opengl? ( virtual/opengl )
- tiff? ( media-libs/tiff )
+ tiff? ( media-libs/tiff:0 )
)"
DEPEND="${RDEPEND}
@@ -107,7 +110,7 @@ src_configure() {
mkdir "${S}"/wxgtk_build
cd "${S}"/wxgtk_build
- ECONF_SOURCE="${S}" econf ${myconf} || die "configure failed."
+ ECONF_SOURCE="${S}" econf ${myconf}
}
src_compile() {
diff --git a/x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild b/x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild
index 79a647b85cb5..c0f00f3e09b0 100644
--- a/x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild,v 1.4 2011/10/25 04:06:33 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.9.1.1.ebuild,v 1.5 2011/11/12 11:09:11 jlec Exp $
EAPI="3"
inherit eutils flag-o-matic
-DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="http://wxwidgets.org/"
# we use the wxPython tarballs because they include the full wxGTK sources and
@@ -21,19 +21,22 @@ RDEPEND="
dev-libs/expat
sdl? ( media-libs/libsdl )
X? (
- >=x11-libs/gtk+-2.18:2
>=dev-libs/glib-2.22:2
+ media-libs/libpng:0
+ sys-libs/zlib
virtual/jpeg
+ >=x11-libs/gtk+-2.18:2
x11-libs/libSM
x11-libs/libXinerama
x11-libs/libXxf86vm
+ x11-libs/pango
gnome? ( gnome-base/libgnomeprintui:2.2 )
gstreamer? (
gnome-base/gconf:2
>=media-libs/gstreamer-0.10
>=media-libs/gst-plugins-base-0.10 )
opengl? ( virtual/opengl )
- tiff? ( media-libs/tiff )
+ tiff? ( media-libs/tiff:0 )
)"
DEPEND="${RDEPEND}
@@ -109,7 +112,7 @@ src_configure() {
mkdir "${S}"/wxgtk_build
cd "${S}"/wxgtk_build
- ECONF_SOURCE="${S}" econf ${myconf} || die "configure failed."
+ ECONF_SOURCE="${S}" econf ${myconf}
}
src_compile() {