summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-05-10 20:08:10 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-05-10 20:08:10 +0000
commiteab16aeb03a4d1ff5ac1649968bbba95b41e6ae2 (patch)
tree26a65a5b0699355cc6a945ebdc6339615ca9bbc4 /x11-libs
parentVersion bump Qt 4.7.3 (diff)
downloadgentoo-2-eab16aeb03a4d1ff5ac1649968bbba95b41e6ae2.tar.gz
gentoo-2-eab16aeb03a4d1ff5ac1649968bbba95b41e6ae2.tar.bz2
gentoo-2-eab16aeb03a4d1ff5ac1649968bbba95b41e6ae2.zip
Version bump Qt 4.7.3
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/ChangeLog7
-rw-r--r--x11-libs/qt-sql/qt-sql-4.7.3.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 1247db45e136..b0de0346cf62 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.107 2011/05/09 22:10:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.108 2011/05/10 20:08:10 tampakrap Exp $
+
+*qt-sql-4.7.3 (10 May 2011)
+
+ 10 May 2011; Theo Chatzimichos <tampakrap@gentoo.org> +qt-sql-4.7.3.ebuild:
+ Version bump Qt 4.7.3
09 May 2011; Markos Chandras <hwoarang@gentoo.org> qt-sql-4.7.2.ebuild:
Stable on amd64 wrt bug #354033
diff --git a/x11-libs/qt-sql/qt-sql-4.7.3.ebuild b/x11-libs/qt-sql/qt-sql-4.7.3.ebuild
new file mode 100644
index 000000000000..2fbae66f1ed6
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.7.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.7.3.ebuild,v 1.1 2011/05/10 20:08:10 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="firebird freetds iconv mysql odbc postgres qt3support +sqlite"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ firebird? ( dev-db/firebird )
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtSql/
+ include/QtScript/
+ src/src.pro
+ src/corelib/
+ src/plugins
+ src/3rdparty
+ src/tools"
+
+ if ! ( use firebird || use freetds || use mysql || use odbc || use postgres || use sqlite );
+ then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird freetds mysql odbc postgres sqlite tds\"."
+ die "Enable at least one SQL driver."
+ fi
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die "sed to fix postgresql usage in ./configure failed"
+}
+
+src_configure() {
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use firebird sql-ibase plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+
+ qt4-build_src_configure
+}