summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-12-10 18:36:36 +0000
committerFabian Groffen <grobian@gentoo.org>2010-12-10 18:36:36 +0000
commitf3d32783aac15261e2cdc56449a560d37910edd7 (patch)
tree5a20e81b509524e21dc4b279103e9dae165e9252 /x11-libs
parentUpdate restrict in metadata per mgorny's request to use DEPEND syntax. (diff)
downloadgentoo-2-f3d32783aac15261e2cdc56449a560d37910edd7.tar.gz
gentoo-2-f3d32783aac15261e2cdc56449a560d37910edd7.tar.bz2
gentoo-2-f3d32783aac15261e2cdc56449a560d37910edd7.zip
Fix installation of private headers for OSX Framework builds, bug #346371
(Portage version: 2.2.01.17304-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-declarative/ChangeLog6
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
index f702e19fc762..8f4b84d5783a 100644
--- a/x11-libs/qt-declarative/ChangeLog
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-declarative
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.15 2010/12/05 18:45:59 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.16 2010/12/10 18:36:36 grobian Exp $
+
+ 10 Dec 2010; Fabian Groffen <grobian@gentoo.org>
+ qt-declarative-4.7.1-r2.ebuild:
+ Fix installation of private headers for OSX Framework builds, bug #346371
*qt-declarative-4.7.1-r2 (05 Dec 2010)
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild
index 45e92ecb141c..6c069c681022 100644
--- a/x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild,v 1.1 2010/12/05 18:45:59 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.1-r2.ebuild,v 1.2 2010/12/10 18:36:36 grobian Exp $
EAPI="3"
inherit qt4-build
@@ -45,7 +45,13 @@ src_configure() {
src_install() {
qt4-build_src_install
if use private-headers; then
- insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
+ # ran for the 2nd time, need it for the updated headers
+ fix_includes
+ else
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ fi
find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
fi
}