summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-18 22:43:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-18 22:43:08 +0000
commitf5f7b0885c801518fe82767d616bd546914acc88 (patch)
tree673152765d6fe231ba1b2c72b4afa7f993bf8f06 /x11-libs
parentstable ppc, bug 259936 (diff)
downloadgentoo-2-f5f7b0885c801518fe82767d616bd546914acc88.tar.gz
gentoo-2-f5f7b0885c801518fe82767d616bd546914acc88.tar.bz2
gentoo-2-f5f7b0885c801518fe82767d616bd546914acc88.zip
Bump to 0.14.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goocanvas/ChangeLog8
-rw-r--r--x11-libs/goocanvas/goocanvas-0.14.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/goocanvas/ChangeLog b/x11-libs/goocanvas/ChangeLog
index a9ca25a8e18f..d4a29c453fca 100644
--- a/x11-libs/goocanvas/ChangeLog
+++ b/x11-libs/goocanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/goocanvas
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.11 2009/01/18 21:14:44 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.12 2009/03/18 22:43:08 eva Exp $
+
+*goocanvas-0.14 (18 Mar 2009)
+
+ 18 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +goocanvas-0.14.ebuild:
+ Bump to 0.14.
*goocanvas-0.13 (18 Jan 2009)
diff --git a/x11-libs/goocanvas/goocanvas-0.14.ebuild b/x11-libs/goocanvas/goocanvas-0.14.ebuild
new file mode 100644
index 000000000000..8dc754d4d2ed
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-0.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-0.14.ebuild,v 1.1 2009/03/18 22:43:08 eva Exp $
+
+EAPI="2"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 libtool
+
+DESCRIPTION="GooCanvas is a canvas widget for GTK+ using the cairo 2D library for drawing."
+HOMEPAGE="http://live.gnome.org/GooCanvas"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/glib-2.10
+ >=x11-libs/cairo-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-rebuilds --disable-static"
+}
+
+src_prepare() {
+ # Fails to build with recent GTK+
+ sed -e "s/-D.*_DISABLE_DEPRECATED//g" \
+ -i src/Makefile.am src/Makefile.in demo/Makefile.am demo/Makefile.in \
+ || die "sed 1 failed"
+
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ # Needed for FreeBSD - Please do not remove
+ elibtoolize
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples/
+ doins demo/*.c demo/flower.png demo/toroid.png
+ fi
+}