summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jarjoura <eklipse@gentoo.org>2004-09-27 18:35:23 +0000
committerMatt Jarjoura <eklipse@gentoo.org>2004-09-27 18:35:23 +0000
commitb9dcbb386acf2de32845084bf468872cacdd8df9 (patch)
tree33373b236a020e929f0617a950ca1abdb977f2cd /x11-misc/Xautoconfig
parentVersion bump, old version unavailable. Closes bug #64845 (Manifest recommit) (diff)
downloadgentoo-2-b9dcbb386acf2de32845084bf468872cacdd8df9.tar.gz
gentoo-2-b9dcbb386acf2de32845084bf468872cacdd8df9.tar.bz2
gentoo-2-b9dcbb386acf2de32845084bf468872cacdd8df9.zip
add patch for writing xorg.conf file if user has that installed
Diffstat (limited to 'x11-misc/Xautoconfig')
-rw-r--r--x11-misc/Xautoconfig/Xautoconfig-0.22-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/Xautoconfig/Xautoconfig-0.22-r1.ebuild b/x11-misc/Xautoconfig/Xautoconfig-0.22-r1.ebuild
new file mode 100644
index 000000000000..9af1187cba55
--- /dev/null
+++ b/x11-misc/Xautoconfig/Xautoconfig-0.22-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation & Pieter Van den Abeele
+# xorg.conf patch (C) 2004 by Matt Jarjoura <eklispe@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/Xautoconfig/Xautoconfig-0.22-r1.ebuild,v 1.1 2004/09/27 18:35:23 eklipse Exp $
+
+inherit eutils
+
+DESCRIPTION="Xautoconfig is a PPC only config file generator for xfree86"
+SRC_URI="http://ftp.penguinppc.org/projects/xautocfg/${P}.tar.gz"
+HOMEPAGE="http://ftp.penguinppc.org/projects/xautocfg/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc -x86 -sparc "
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+
+src_unpack() {
+ if [ ${ARCH} != ppc ]
+ then
+ die "This is a PPC-only package"
+ fi
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/Xautoconfig.patch || die
+ epatch ${FILESDIR}/XF4text.h.diff || die
+}
+
+src_compile() {
+ make || die "sorry, failed to compile Xautoconfig (PPC-only ebuild)"
+}
+
+src_install() {
+
+ dodir /usr/X11R6/
+ into /usr/X11R6/
+ dobin Xautoconfig4
+
+ dodoc ChangeLog
+
+}