summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-11 17:36:47 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-11 17:36:47 +0000
commit85dba0c72e26f8dcef3b2d1c8f6047e7469ae56f (patch)
treec9f27c828e0d68f2b6a4b578268fee5cdb5c2b5f /x11-misc/devilspie
parentalpha/sparc stable wrt #198736 and remove old (diff)
downloadgentoo-2-85dba0c72e26f8dcef3b2d1c8f6047e7469ae56f.tar.gz
gentoo-2-85dba0c72e26f8dcef3b2d1c8f6047e7469ae56f.tar.bz2
gentoo-2-85dba0c72e26f8dcef3b2d1c8f6047e7469ae56f.zip
remove unused patches
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-misc/devilspie')
-rw-r--r--x11-misc/devilspie/files/SYNTAX-0.1698
-rw-r--r--x11-misc/devilspie/files/devilspie-0.10-make-check.patch34
-rw-r--r--x11-misc/devilspie/files/devilspie-0.16-README.patch13
3 files changed, 0 insertions, 145 deletions
diff --git a/x11-misc/devilspie/files/SYNTAX-0.16 b/x11-misc/devilspie/files/SYNTAX-0.16
deleted file mode 100644
index f7ec7f7d2710..000000000000
--- a/x11-misc/devilspie/files/SYNTAX-0.16
+++ /dev/null
@@ -1,98 +0,0 @@
-Built-ins
-=========
-
-Types:
- - "string": A string.
- - 1, 2, 3: Integers
- - #t, #f: Booleans.
-
-Boolean operations:
- - (and bool*) -> bool: perform a boolean AND of boolean values
- - (or bool*) -> bool: perform a boolean OR of boolean values
-
-Addition, substraction:
- - (+ int*) -> int: add integers
- - (+ string*) -> string: concat strings
- - (- int int*) -> int: subtract integers from the first
-
-Types casting:
- - (cast-int string|int|bool) -> int: cast to an integer value
- - (cast-string string|int|bool) -> string: cast to an string value
-
-Comparison operators:
- - (<|>|= int int) -> bool: compare two integers
- - (<|>|= string string) -> bool: compare two strings
-
-Function flow:
- - (if bool func) -> type: execute a function if the condition holds
- - (if bool func func) -> type: choose what function to execute depending on the
- condition
- - (begin func func*) -> type: execute a sequence of functions, and return the
- result of the last one
-
-
-Logical operations
-==================
-
-This are predicates you can use to test strings, for instance in "if"
-conditions.
-
- - (is string string) -> bool: return #t if the two strings are the same
- Example: (if (is (application_name) "XMMS") ...)
- - (contains string string) -> bool: return #t if the second string is a
- substring of the first one.
- Example: (if (contains (application_name) "term") ...)
- - (matches string string) -> bool: return #t if the second string is a regular
- expression matching the first one.
- Example: (if (matches (window_name) "^Character.+") ...)
-
-
-Matchers
-========
-
-Matchers are functions which return informations about windows. You can for
-instance use them in "if" condition to match some particular windows.
-
- - (window_name) -> string: return the title of the current window
- - (application_name) -> string: return the application name of the current
- window, as determined by libwnck
- - (window_role) -> string: return the role of the current window, as determined
- by the WM_WINDOW_ROLE hint
- - (window_class) -> string: return the class of the current window
-
-
-Actions
-=======
-
-Actions are the functions you can use to change some window properties.
-All actions return booleans (TRUE on success, FALSE on failure).
-
- - (debug): debugging function - print informations about current window
- - (print args*): print all arguments
- - (geometry string): set size and/or position of a window. Examples:
- (if ... (geometry "600x600"))
- (if ... (geometry "+200+200"))
- (if ... (geometry "600x600+200+200"))
- - (fullscreen): make the current window fullscreen
- - (focus): focus the current window
- - (center): center position of current window
- - (maximize): maximize the current window
- - (maximize_vertically): maximize the current window vertically
- - (maximize_horizontally): maximize the current window horizontally
- - (minimize): minimize the current window
- - (shade): shade ("roll up") the current window
- - (unshade): unshade ("roll down") the current window
- - (close): close the current window
- - (pin): pin the current window to all workspaces
- - (unpin): unpin the current window from all workspaces
- - (set_workspace int): move the window to a specific workspace number,
- counting from 1
- - (skip_pager): remove the current window from the pager
- - (skip_tasklist): remove the current window from the window list
- - (above): set the current window to be above all normal windows
- - (below): set the current window to be below all normal windows
- - (undecorate): remove the window manager decorations from the current window
- - (wintype string): set the window type of the current window. Accepted values
- are: "normal", "dialog", "menu", "toolbar", "splashscreen", "utility",
- "dock" and "desktop".
-
diff --git a/x11-misc/devilspie/files/devilspie-0.10-make-check.patch b/x11-misc/devilspie/files/devilspie-0.10-make-check.patch
deleted file mode 100644
index e2077f553215..000000000000
--- a/x11-misc/devilspie/files/devilspie-0.10-make-check.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -urp devilspie-0.10/src/Makefile.am devilspie-0.10-make-check/src/Makefile.am
---- devilspie-0.10/src/Makefile.am 2005-04-29 08:52:02.000000000 +0200
-+++ devilspie-0.10-make-check/src/Makefile.am 2005-06-11 16:45:45.000000000 +0200
-@@ -31,6 +31,8 @@ parser_test_SOURCES = \
- config-parser.c \
- flurb.h \
- flurb.c \
-+ xutils.h \
-+ xutils.c \
- devilspie.h \
- parser-test.c
-
-diff -urp devilspie-0.10/src/Makefile.in devilspie-0.10-make-check/src/Makefile.in
---- devilspie-0.10/src/Makefile.in 2005-05-04 22:20:30.000000000 +0200
-+++ devilspie-0.10-make-check/src/Makefile.in 2005-06-11 16:52:21.000000000 +0200
-@@ -131,7 +131,7 @@ devilspie_SOURCES = ${BUILT_SOURCES}
- doc_generator_SOURCES = ${BUILT_SOURCES} flurb.h flurb.c xutils.h xutils.c doc-generator.c
-
-
--parser_test_SOURCES = ${BUILT_SOURCES} config-parser.c flurb.h flurb.c devilspie.h parser-test.c
-+parser_test_SOURCES = ${BUILT_SOURCES} config-parser.c flurb.h xutils.h xutils.c flurb.c devilspie.h parser-test.c
-
-
- INCLUDES = $(WNCK_CFLAGS) -DDEVILSPIE_LOCALEDIR=\""$(datadir)/locale"\" -DDATADIR=\""$(datadir)"\" -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED
-@@ -186,7 +186,8 @@ devilspie-action-exec.o devilspie-action
- devilspie-action-layer.o devilspie-action-opacity.o \
- devilspie-action-resize.o devilspie-action-savegeometry.o \
- devilspie-action-setgeometry.o devilspie-action-setwintype.o \
--devilspie-action-setworkspace.o config-parser.o flurb.o parser-test.o
-+devilspie-action-setworkspace.o config-parser.o flurb.o xutils.o \
-+parser-test.o
- parser_test_LDADD = $(LDADD)
- parser_test_DEPENDENCIES =
- parser_test_LDFLAGS =
diff --git a/x11-misc/devilspie/files/devilspie-0.16-README.patch b/x11-misc/devilspie/files/devilspie-0.16-README.patch
deleted file mode 100644
index b20d4fb9f7d1..000000000000
--- a/x11-misc/devilspie/files/devilspie-0.16-README.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- README.orig 2005-11-11 14:37:49.880121000 +0100
-+++ README 2005-11-11 14:40:09.350121000 +0100
-@@ -76,8 +76,8 @@
- s-expression puts the window on workspace 2, maximised, if the window name
- begins with "Character" and has more characters in (note .+ rather than .*).
-
--I will write more documentation in the future but for now you'll have to look at
--the "symbols" array in src/parser.c to see what functions are available.
-+For a complete syntax reference of s-expressions, see the SYNTAX file in the
-+documentation directory.
-
-
- Running