summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-03 12:15:00 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-03 12:15:00 +0000
commit14f2d9af9bbe472e018154161808359ff0b47607 (patch)
tree8ea6b625795a9440b4db92226cda81da52ba6708 /x11-misc/fbdesk
parentMark 1.58-r1 stable on ia64 (diff)
downloadgentoo-2-14f2d9af9bbe472e018154161808359ff0b47607.tar.gz
gentoo-2-14f2d9af9bbe472e018154161808359ff0b47607.tar.bz2
gentoo-2-14f2d9af9bbe472e018154161808359ff0b47607.zip
Cleaned up ebuild: fixed LICENSE (its MIT not GPL-2), fixed DEPEND (libpng was specified twice, one conditional on USE=png and one unconditional...); also use make DESTDIR=${D} install over einstall.
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'x11-misc/fbdesk')
-rw-r--r--x11-misc/fbdesk/ChangeLog7
-rw-r--r--x11-misc/fbdesk/Manifest16
-rw-r--r--x11-misc/fbdesk/fbdesk-1.2.1.ebuild20
3 files changed, 18 insertions, 25 deletions
diff --git a/x11-misc/fbdesk/ChangeLog b/x11-misc/fbdesk/ChangeLog
index d0278a25f844..267e055f065e 100644
--- a/x11-misc/fbdesk/ChangeLog
+++ b/x11-misc/fbdesk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/fbdesk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.14 2005/05/16 06:07:31 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.15 2005/10/03 12:15:00 ka0ttic Exp $
+
+ 03 Oct 2005; Aaron Walker <ka0ttic@gentoo.org> fbdesk-1.2.1.ebuild:
+ Cleaned up ebuild: fixed LICENSE (its MIT not GPL-2), fixed DEPEND (libpng
+ was specified twice, one conditional on USE=png and one unconditional...);
+ also use make DESTDIR=${D} install over einstall.
16 May 2005; Aaron Walker <ka0ttic@gentoo.org> fbdesk-1.1.5.ebuild,
fbdesk-1.2.1.ebuild:
diff --git a/x11-misc/fbdesk/Manifest b/x11-misc/fbdesk/Manifest
index 084b4f8c2140..72f9bc245a70 100644
--- a/x11-misc/fbdesk/Manifest
+++ b/x11-misc/fbdesk/Manifest
@@ -1,17 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 61711b0a572618f7a20bb24eb1ce2381 fbdesk-1.2.1.ebuild 747
+MD5 cce86a47a7a1cedfa351414217d5f63e ChangeLog 1998
MD5 fe8932509357e388b8132cd283f57e6d fbdesk-1.1.5.ebuild 687
-MD5 d11efa95fcc1200f0ac198e40913662a ChangeLog 1721
-MD5 416452bedba085c06bd2502510370e1a metadata.xml 162
+MD5 9781e1d64e70cbfa729f52454d68e918 fbdesk-1.2.1.ebuild 784
MD5 39b789020c286f3f1239d3fb96d00aa0 files/digest-fbdesk-1.1.5 64
MD5 c9802bbcd01212346c3bff9690a74759 files/digest-fbdesk-1.2.1 64
MD5 6c03b221f71103953d36a49670e85246 files/fbdesk-1.1.5-gcc34.patch 2462
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCiDivEZCkKN40op4RAnzGAJ4+uxMfu5NxG+7YBWcSLojFpQ7M7ACgiiHx
-V5PIDtbZ39X1ohUoP4GCiLE=
-=J8hn
------END PGP SIGNATURE-----
+MD5 416452bedba085c06bd2502510370e1a metadata.xml 162
diff --git a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
index 1dde8942a393..5059ae24bd94 100644
--- a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.4 2005/05/16 06:07:31 ka0ttic Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.5 2005/10/03 12:15:00 ka0ttic Exp $
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://www.fluxbox.org/fbdesk/"
SRC_URI="http://www.fluxbox.org/download/${P}.tar.gz"
-IUSE="debug png"
-LICENSE="GPL-2"
+LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ppc ~sparc ia64 ~amd64"
+IUSE="debug png"
-DEPEND="media-libs/libpng
- virtual/x11
+DEPEND="virtual/x11
png? ( media-libs/libpng )"
src_compile() {
econf \
- `use_enable debug` \
- `use_enable png` || die
- emake || die
+ $(use_enable debug) \
+ $(use_enable png) || die "econf failed"
+
+ emake || die "emake failed"
}
src_install() {
- einstall || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS COPYING ChangeLog README
}