summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-11 12:24:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-11 12:24:57 +0000
commit64512c4614f5c00894452ce2300760e76c95be65 (patch)
tree5ac22588e90bcdb0bbc68883345430a44da339d3 /x11-misc/fbdesk
parentAdd rtkit support using toggled by the 'realtime' USE flag (diff)
downloadgentoo-2-64512c4614f5c00894452ce2300760e76c95be65.tar.gz
gentoo-2-64512c4614f5c00894452ce2300760e76c95be65.tar.bz2
gentoo-2-64512c4614f5c00894452ce2300760e76c95be65.zip
Fix building with libpng14.
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/fbdesk')
-rw-r--r--x11-misc/fbdesk/ChangeLog8
-rw-r--r--x11-misc/fbdesk/fbdesk-1.4.1.ebuild31
-rw-r--r--x11-misc/fbdesk/files/fbdesk-1.4.1-libpng14.patch11
3 files changed, 31 insertions, 19 deletions
diff --git a/x11-misc/fbdesk/ChangeLog b/x11-misc/fbdesk/ChangeLog
index b99dba90f00f..7668c788dbc4 100644
--- a/x11-misc/fbdesk/ChangeLog
+++ b/x11-misc/fbdesk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fbdesk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.33 2009/05/03 19:37:51 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.34 2010/03/11 12:24:56 ssuominen Exp $
+
+ 11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> fbdesk-1.4.1.ebuild,
+ +files/fbdesk-1.4.1-libpng14.patch:
+ Fix building with libpng14.
03 May 2009; Ryan Hill <dirtyepic@gentoo.org> fbdesk-1.4.1.ebuild:
Add missing freetype dependency for bug #227729.
diff --git a/x11-misc/fbdesk/fbdesk-1.4.1.ebuild b/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
index 48689a957118..628a1d316022 100644
--- a/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.4.1.ebuild,v 1.9 2009/05/03 19:37:51 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.4.1.ebuild,v 1.10 2010/03/11 12:24:56 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
@@ -14,29 +15,25 @@ KEYWORDS="amd64 ia64 ppc sparc x86"
IUSE="debug png"
RDEPEND="png? ( media-libs/libpng )
- media-libs/imlib2
- >=media-libs/freetype-2
- x11-libs/libXpm
- x11-libs/libXft"
+ media-libs/imlib2
+ >=media-libs/freetype-2
+ x11-libs/libXpm
+ x11-libs/libXft"
DEPEND="${RDEPEND}
- x11-proto/xextproto"
+ x11-proto/xextproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
}
-src_compile() {
+src_configure() {
econf \
$(use_enable debug) \
- $(use_enable png) || die "econf failed"
-
- emake || die "emake failed"
+ $(use_enable png)
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README
}
diff --git a/x11-misc/fbdesk/files/fbdesk-1.4.1-libpng14.patch b/x11-misc/fbdesk/files/fbdesk-1.4.1-libpng14.patch
new file mode 100644
index 000000000000..472df8b742e5
--- /dev/null
+++ b/x11-misc/fbdesk/files/fbdesk-1.4.1-libpng14.patch
@@ -0,0 +1,11 @@
+--- src/FbTk/ImagePNG.cc
++++ src/FbTk/ImagePNG.cc
+@@ -88,7 +88,7 @@
+ // check header
+ unsigned char tag[4];
+ fread(tag, 1, 4, fp);
+- if (!png_check_sig(tag, 4)) {
++ if (png_sig_cmp(tag, 0, 4)) {
+ fclose(fp);
+ return 0;
+ }