summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-02 07:47:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-02 07:47:53 +0000
commit3840001606dbac73c29920ace83fa66789a5652a (patch)
treec568a24429b002df610ece7ea6d7f5559ba8ca14 /x11-misc/grabc/grabc-1.1.ebuild
parentinitial commit (bug 21170) (diff)
downloadgentoo-2-3840001606dbac73c29920ace83fa66789a5652a.tar.gz
gentoo-2-3840001606dbac73c29920ace83fa66789a5652a.tar.bz2
gentoo-2-3840001606dbac73c29920ace83fa66789a5652a.zip
initial commit (bug 21170)
Diffstat (limited to 'x11-misc/grabc/grabc-1.1.ebuild')
-rw-r--r--x11-misc/grabc/grabc-1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/grabc/grabc-1.1.ebuild b/x11-misc/grabc/grabc-1.1.ebuild
new file mode 100644
index 000000000000..21912146f206
--- /dev/null
+++ b/x11-misc/grabc/grabc-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/grabc/grabc-1.1.ebuild,v 1.1 2003/10/02 07:47:40 mr_bones_ Exp $
+
+S="${WORKDIR}/${PN}${PV}"
+DESCRIPTION="A simple but useful program to determine the color string in hex (or RGB components) by clicking on a pixel on the screen"
+HOMEPAGE="http://www.muquit.com/muquit/software/grabc/grabc.html"
+SRC_URI="http://www.muquit.com/muquit/software/${PN}/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s/-O/${CFLAGS}/" Makefile || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin grabc || die "dobin failed"
+ dodoc README || die "dodoc failed"
+}