summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-07-03 12:01:48 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-07-03 12:01:48 +0000
commit7920ead70a9cc5153ad3045cac80f731f3afc2d4 (patch)
tree12a4302fff34cec67bf069b479fed4d275dd15d6 /x11-misc/gtodo
parentMove wxPython to wxpython. (diff)
downloadgentoo-2-7920ead70a9cc5153ad3045cac80f731f3afc2d4.tar.gz
gentoo-2-7920ead70a9cc5153ad3045cac80f731f3afc2d4.tar.bz2
gentoo-2-7920ead70a9cc5153ad3045cac80f731f3afc2d4.zip
Added gtodo-applet support. Closing bug #44233.
Diffstat (limited to 'x11-misc/gtodo')
-rw-r--r--x11-misc/gtodo/ChangeLog5
-rw-r--r--x11-misc/gtodo/Manifest6
-rw-r--r--x11-misc/gtodo/files/digest-gtodo-0.141
-rw-r--r--x11-misc/gtodo/gtodo-0.14.ebuild32
4 files changed, 37 insertions, 7 deletions
diff --git a/x11-misc/gtodo/ChangeLog b/x11-misc/gtodo/ChangeLog
index 1891f99fd8f0..d230841dc6dc 100644
--- a/x11-misc/gtodo/ChangeLog
+++ b/x11-misc/gtodo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/gtodo
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gtodo/ChangeLog,v 1.8 2004/06/24 22:21:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gtodo/ChangeLog,v 1.9 2004/07/03 12:01:48 pyrania Exp $
+
+ 03 Jul 2004; <pyrania@gentoo.org> gtodo-0.14.ebuild:
+ Added gtodo-applet support. Closing bug #44233.
15 Jun 2004; Ian Leitch <port001@gentoo.org> gtodo-0.13.5.ebuild,
gtodo-0.14.ebuild:
diff --git a/x11-misc/gtodo/Manifest b/x11-misc/gtodo/Manifest
index 3a545bb63bd5..db5a1f827943 100644
--- a/x11-misc/gtodo/Manifest
+++ b/x11-misc/gtodo/Manifest
@@ -1,6 +1,6 @@
-MD5 122f0bb151a052d8d2e47798d183a5e5 ChangeLog 1012
MD5 7204274a8d5a1fc3235fbe4978ee2f78 gtodo-0.13.5.ebuild 693
-MD5 15057a517b0b56f76e07bac7bc174f8b gtodo-0.14.ebuild 690
+MD5 122f0bb151a052d8d2e47798d183a5e5 ChangeLog 1012
MD5 09ccef8f0c71ece39e0fd0f5c8265ea6 metadata.xml 367
+MD5 249786606660a0a5b5cb71931e5273c8 gtodo-0.14.ebuild 1253
+MD5 636f22b2a6529fa06fadbd19c34c8250 files/digest-gtodo-0.14 130
MD5 bed7bdda997259ea2a0f92edbd892056 files/digest-gtodo-0.13.5 64
-MD5 03e5c63c35172afa1ae9d8960f9f2442 files/digest-gtodo-0.14 62
diff --git a/x11-misc/gtodo/files/digest-gtodo-0.14 b/x11-misc/gtodo/files/digest-gtodo-0.14
index adee31859bfc..9142543d1340 100644
--- a/x11-misc/gtodo/files/digest-gtodo-0.14
+++ b/x11-misc/gtodo/files/digest-gtodo-0.14
@@ -1 +1,2 @@
MD5 51f5d71c51374931a24cce1839402457 gtodo-0.14.tar.gz 198798
+MD5 fa24af55422a09768acabc43698ee097 gtodo-applet-0.1.tar.gz 303635
diff --git a/x11-misc/gtodo/gtodo-0.14.ebuild b/x11-misc/gtodo/gtodo-0.14.ebuild
index 9aab807230c6..4046e9d5a1c1 100644
--- a/x11-misc/gtodo/gtodo-0.14.ebuild
+++ b/x11-misc/gtodo/gtodo-0.14.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gtodo/gtodo-0.14.ebuild,v 1.7 2004/06/25 22:34:17 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gtodo/gtodo-0.14.ebuild,v 1.8 2004/07/03 12:01:48 pyrania Exp $
inherit debug flag-o-matic gnome2
strip-flags
-IUSE=""
+IUSE="gnome"
DESCRIPTION="Gtodo is a Gtk+-2.0 Todo list manager written for use with gnome 2."
HOMEPAGE="http://gtodo.qballcow.nl/"
-SRC_URI="mirror://sourceforge/gtodo/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/gtodo/${P}.tar.gz
+ gnome? ( http://download.qballcow.nl/programs/${PN}/${PN}-applet-0.1.tar.gz )"
KEYWORDS="x86 amd64"
SLOT="0"
LICENSE="GPL-2"
@@ -23,3 +24,28 @@ DEPEND=">=x11-libs/gtk+-2.0
>=gnome-base/gnome-vfs-2.0"
DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+src_compile(){
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ # Gnome Applet
+ use gnome && (
+ einfo "Building Gnome Applet..."
+ cd ${S}/../gtodo-applet-0.1
+ econf || die "applet econf failed"
+ emake || die "applet emake failed"
+ )
+}
+
+src_install(){
+ addwrite /etc/gconf
+ einstall || die "einstall failed"
+
+ # Install Gnome Applet
+ use gnome && (
+ einfo "Installing Gnome Applet..."
+ cd ${S}/../gtodo-applet-0.1
+ einstall || die "applet einstall failed"
+ )
+}