summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-20 07:30:59 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-20 07:30:59 +0000
commit2e37c7db79d30b4dcd5dc2fea4b1947aadf09bd6 (patch)
treed6f1117fcdab745c2b3e3d8ace46190469dcb89c /x11-misc/idesk
parentversion bump (diff)
downloadgentoo-2-2e37c7db79d30b4dcd5dc2fea4b1947aadf09bd6.tar.gz
gentoo-2-2e37c7db79d30b4dcd5dc2fea4b1947aadf09bd6.tar.bz2
gentoo-2-2e37c7db79d30b4dcd5dc2fea4b1947aadf09bd6.zip
Fix building with GLIBC 2.12 wrt bug 333151. Thanks to Charlie Gehlin <charlie@gehlin.com> for report and scavenging patch.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/idesk')
-rw-r--r--x11-misc/idesk/ChangeLog11
-rw-r--r--x11-misc/idesk/files/idesk-0.7.5-glibc-2.12.patch17
-rw-r--r--x11-misc/idesk/idesk-0.7.5-r2.ebuild45
3 files changed, 71 insertions, 2 deletions
diff --git a/x11-misc/idesk/ChangeLog b/x11-misc/idesk/ChangeLog
index e1f8ce0b281e..badd997944a6 100644
--- a/x11-misc/idesk/ChangeLog
+++ b/x11-misc/idesk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/idesk
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/ChangeLog,v 1.51 2008/05/06 13:39:18 drac Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/ChangeLog,v 1.52 2010/08/20 07:30:57 xarthisius Exp $
+
+*idesk-0.7.5-r2 (20 Aug 2010)
+
+ 20 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +idesk-0.7.5-r2.ebuild, +files/idesk-0.7.5-glibc-2.12.patch:
+ Fix building with GLIBC 2.12 wrt bug 333151. Thanks to Charlie Gehlin
+ <charlie@gehlin.com> for report and scavenging patch.
06 May 2008; Samuli Suominen <drac@gentoo.org> idesk-0.7.5-r1.ebuild:
Move pkgconfig to DEPEND wrt #217278.
diff --git a/x11-misc/idesk/files/idesk-0.7.5-glibc-2.12.patch b/x11-misc/idesk/files/idesk-0.7.5-glibc-2.12.patch
new file mode 100644
index 000000000000..c4ac03e206e9
--- /dev/null
+++ b/x11-misc/idesk/files/idesk-0.7.5-glibc-2.12.patch
@@ -0,0 +1,17 @@
+Fixes build with glibc-2.12
+
+http://bugs.gentoo.org/333515
+https://bugs.launchpad.net/ubuntu/+source/idesk/+bug/592602
+
+Patch written by Bhavani Shankar <bhavi@ubuntu.com>
+--- idesk-0.7.5/src/DesktopConfig.cpp
++++ idesk-0.7.5/src/DesktopConfig.cpp
+@@ -24,6 +24,8 @@
+
+ #include "DesktopConfig.h"
+ #include "Util.h"
++#include <sys/types.h> // For stat()
++#include <sys/stat.h> // For stat()
+
+ //the initilizer list just sets the program defaults for non-necessary options
+ DesktopConfig::DesktopConfig(Database db, string ideskrcFile) :
diff --git a/x11-misc/idesk/idesk-0.7.5-r2.ebuild b/x11-misc/idesk/idesk-0.7.5-r2.ebuild
new file mode 100644
index 000000000000..07a04298ee61
--- /dev/null
+++ b/x11-misc/idesk/idesk-0.7.5-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/idesk-0.7.5-r2.ebuild,v 1.1 2010/08/20 07:30:57 xarthisius Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Utility to place icons on the root window"
+HOMEPAGE="http://idesk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/imlib2-1.4[X]
+ media-libs/freetype
+ dev-libs/libxml2
+ dev-libs/glib:2
+ gnome-extra/libgsf
+ x11-libs/pango
+ x11-libs/gtk+:2
+ media-libs/libart_lgpl
+ x11-libs/startup-notification"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's,/usr/local/,/usr/,' \
+ examples/default.lnk || die
+ epatch "${FILESDIR}"/${P}-glibc-2.12.patch #333515
+}
+
+src_configure() {
+ econf \
+ --enable-libsn
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS NEWS TODO || die
+}