summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2006-10-27 06:53:59 +0000
committerDavid Shakaryan <omp@gentoo.org>2006-10-27 06:53:59 +0000
commit8fd335b229609dbdb3bbd16b482f21975da27111 (patch)
treea8f73dc2f8cfe81fef0cfc4b377799aad23afd59 /x11-misc/lineakconfig
parentMinor cleanup and remove monolithic X from dependencies. (diff)
downloadgentoo-2-8fd335b229609dbdb3bbd16b482f21975da27111.tar.gz
gentoo-2-8fd335b229609dbdb3bbd16b482f21975da27111.tar.bz2
gentoo-2-8fd335b229609dbdb3bbd16b482f21975da27111.zip
Change `` to $(), fix quotes and add die messages.
(Portage version: 2.1.2_pre3-r8)
Diffstat (limited to 'x11-misc/lineakconfig')
-rw-r--r--x11-misc/lineakconfig/ChangeLog6
-rw-r--r--x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild20
2 files changed, 14 insertions, 12 deletions
diff --git a/x11-misc/lineakconfig/ChangeLog b/x11-misc/lineakconfig/ChangeLog
index 5be8b3531b16..528a28417f21 100644
--- a/x11-misc/lineakconfig/ChangeLog
+++ b/x11-misc/lineakconfig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/lineakconfig
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakconfig/ChangeLog,v 1.12 2006/04/10 20:54:22 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakconfig/ChangeLog,v 1.13 2006/10/27 06:53:59 omp Exp $
+
+ 27 Oct 2006; David Shakaryan <omp@gentoo.org>
+ lineakconfig-0.4.1b-r2.ebuild:
+ Change `` to $(), fix quotes and add die messages.
*lineakconfig-0.4.1b-r2 (10 Apr 2006)
diff --git a/x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild b/x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild
index 4ce9f002e9fa..6adcb5cc0072 100644
--- a/x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild
+++ b/x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild,v 1.1 2006/04/10 20:54:22 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakconfig/lineakconfig-0.4.1b-r2.ebuild,v 1.2 2006/10/27 06:53:59 omp Exp $
inherit eutils
-IUSE="nls"
-
DESCRIPTION="Linux support for Easy Access and Internet Keyboards features X11 support"
HOMEPAGE="http://lineak.sourceforge.net/"
SRC_URI="mirror://sourceforge/lineak/${P}.tar.gz"
@@ -13,25 +11,25 @@ SRC_URI="mirror://sourceforge/lineak/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
+IUSE="nls"
RDEPEND="x11-misc/lineakd
=x11-libs/gtk+-1.2*"
-
-DEPEND="nls? ( sys-devel/gettext )
- ${RDEPEND}"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/lineakconfig-${PV}-malloc.patch
- cd ${S}
+ epatch "${FILESDIR}/lineakconfig-${PV}-malloc.patch"
+ cd "${S}"
sed -e "s|doc/"${PN}"|share/doc/"${P}"|g" -i Makefile.in || die
}
src_compile() {
- econf `use_enable nls` || die
- emake || die
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- einstall || die
+ einstall || die "einstall failed"
}