summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-10-04 06:13:29 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-10-04 06:13:29 +0000
commit2a2287fa46259ad945d27f4f8128e9f25e4b4e0f (patch)
treebaf6d44462814e234b08ca13a518ce9428defc2b /x11-misc/linuxwacom
parentUpdate dep from temporary hack to virtual/x11. (Manifest recommit) (diff)
downloadgentoo-2-2a2287fa46259ad945d27f4f8128e9f25e4b4e0f.tar.gz
gentoo-2-2a2287fa46259ad945d27f4f8128e9f25e4b4e0f.tar.bz2
gentoo-2-2a2287fa46259ad945d27f4f8128e9f25e4b4e0f.zip
Update logic to consider that the sdk USE flag may be set without xfree or xorg-x11 installed.
Diffstat (limited to 'x11-misc/linuxwacom')
-rw-r--r--x11-misc/linuxwacom/ChangeLog7
-rw-r--r--x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild7
-rw-r--r--x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild7
3 files changed, 16 insertions, 5 deletions
diff --git a/x11-misc/linuxwacom/ChangeLog b/x11-misc/linuxwacom/ChangeLog
index 3522aff97515..39f8eac66518 100644
--- a/x11-misc/linuxwacom/ChangeLog
+++ b/x11-misc/linuxwacom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/linuxwacom
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.14 2004/10/04 06:02:05 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.15 2004/10/04 06:13:29 spyderous Exp $
+
+ 03 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ linuxwacom-0.6.2.ebuild, linuxwacom-0.6.3.ebuild:
+ Update logic to consider that the sdk USE flag may be set without xfree or
+ xorg-x11 installed.
03 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>;
linuxwacom-0.6.2.ebuild, linuxwacom-0.6.3.ebuild:
diff --git a/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild b/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
index 3fb978f8b40d..9946ce03034c 100644
--- a/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
+++ b/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild,v 1.10 2004/10/04 06:02:05 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild,v 1.11 2004/10/04 06:13:29 spyderous Exp $
DESCRIPTION="Input driver for Wacom tablets and drawing devices"
HOMEPAGE="http://linuxwacom.sourceforge.net/"
@@ -33,12 +33,15 @@ pkg_setup() {
eerror "that you have emerged xfree with the sdk USE flag enabled."
die "Please remerge xfree with the sdk USE flag enabled."
fi
- else if [ ! "`grep sdk /var/db/pkg/x11-base/xorg-x11-[0-9]*/USE`" ]
+ elif has_version "x11-base/xorg-x11"
+ then
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xorg-x11-[0-9]*/USE`" ]
then
eerror "This package builds against the X.Org SDK, and therefore requires"
eerror "that you have emerged xorg-x11 with the sdk USE flag enabled."
die "Please remerge xorg-x11 with the sdk USE flag enabled."
fi
+ else die "This build requires x11-base/xorg-x11 or x11-base/xfree to be installed to build against the SDK when USE=sdk."
fi
einfo "Building against the X11 SDK. This will install updated X drivers and userland tools."
else
diff --git a/x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild b/x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild
index db7df1422edc..ffc7f9964cea 100644
--- a/x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild
+++ b/x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild,v 1.8 2004/10/04 06:02:05 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.3.ebuild,v 1.9 2004/10/04 06:13:29 spyderous Exp $
DESCRIPTION="Input driver for Wacom tablets and drawing devices"
HOMEPAGE="http://linuxwacom.sourceforge.net/"
@@ -33,12 +33,15 @@ pkg_setup() {
eerror "that you have emerged xfree with the sdk USE flag enabled."
die "Please remerge xfree with the sdk USE flag enabled."
fi
- else if [ ! "`grep sdk /var/db/pkg/x11-base/xorg-x11-[0-9]*/USE`" ]
+ elif has_version "x11-base/xorg-x11"
+ then
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xorg-x11-[0-9]*/USE`" ]
then
eerror "This package builds against the X.Org SDK, and therefore requires"
eerror "that you have emerged xorg-x11 with the sdk USE flag enabled."
die "Please remerge xorg-x11 with the sdk USE flag enabled."
fi
+ else die "This build requires x11-base/xorg-x11 or x11-base/xfree to be installed to build against the SDK when USE=sdk."
fi
einfo "Building against the X11 SDK. This will install updated X drivers and userland tools."
else