summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-03-02 17:59:01 +0000
committerKevin McCarthy <signals@gentoo.org>2011-03-02 17:59:01 +0000
commit38344dcea50e340829a69c3e4377202d41e56056 (patch)
tree5208e0c9ac4d16083cf62108dd9bf521a38ae953 /x11-misc/parcellite
parentCorrect Slots for gtk 3 introduction to tree (diff)
downloadgentoo-2-38344dcea50e340829a69c3e4377202d41e56056.tar.gz
gentoo-2-38344dcea50e340829a69c3e4377202d41e56056.tar.bz2
gentoo-2-38344dcea50e340829a69c3e4377202d41e56056.zip
Slotted gtk+ and glib depends and EAPI=2 bump to support it.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/parcellite')
-rw-r--r--x11-misc/parcellite/ChangeLog5
-rw-r--r--x11-misc/parcellite/parcellite-0.9.1.ebuild14
2 files changed, 13 insertions, 6 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 0422dde5a543..1c71b0d00c65 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.9 2011/01/21 18:45:56 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.10 2011/03/02 17:59:01 signals Exp $
+
+ 02 Mar 2011; Kevin McCarthy <signals@gentoo.org> parcellite-0.9.1.ebuild:
+ Slotted gtk+ and glib depends and EAPI=2 bump to support it.
*parcellite-0.9.3 (21 Jan 2011)
diff --git a/x11-misc/parcellite/parcellite-0.9.1.ebuild b/x11-misc/parcellite/parcellite-0.9.1.ebuild
index 103c54c6039a..886713e2154b 100644
--- a/x11-misc/parcellite/parcellite-0.9.1.ebuild
+++ b/x11-misc/parcellite/parcellite-0.9.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-0.9.1.ebuild,v 1.2 2009/10/03 17:08:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-0.9.1.ebuild,v 1.3 2011/03/02 17:59:01 signals Exp $
+EAPI=2
inherit fdo-mime
DESCRIPTION="A lightweight GTK+ based clipboard manager."
@@ -13,15 +14,18 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND=">=x11-libs/gtk+-2.10
- >=dev-libs/glib-2.14"
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext
dev-util/intltool )"
-src_compile() {
+src_configure() {
econf --disable-dependency-tracking $(use_enable nls)
+}
+
+src_compile() {
emake || die "emake failed."
}