summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-21 18:45:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-21 18:45:56 +0000
commitf1c069bf911123cb359b109e80fd70d95567155c (patch)
tree5b29f6261917c6b3cf607e29b19bf510f57ddf21 /x11-misc/parcellite
parentUnmask mail-mta/postfix-2.8.0. (diff)
downloadgentoo-2-f1c069bf911123cb359b109e80fd70d95567155c.tar.gz
gentoo-2-f1c069bf911123cb359b109e80fd70d95567155c.tar.bz2
gentoo-2-f1c069bf911123cb359b109e80fd70d95567155c.zip
Version bump. Bug #351324
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/parcellite')
-rw-r--r--x11-misc/parcellite/ChangeLog9
-rw-r--r--x11-misc/parcellite/parcellite-0.9.3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index f4b23d6ea4fa..0422dde5a543 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/parcellite
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.8 2010/02/24 18:40:41 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.9 2011/01/21 18:45:56 hwoarang Exp $
+
+*parcellite-0.9.3 (21 Jan 2011)
+
+ 21 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +parcellite-0.9.3.ebuild:
+ Version bump. Bug #351324
*parcellite-0.9.2 (24 Feb 2010)
diff --git a/x11-misc/parcellite/parcellite-0.9.3.ebuild b/x11-misc/parcellite/parcellite-0.9.3.ebuild
new file mode 100644
index 000000000000..e35f874f370c
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-0.9.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-0.9.3.ebuild,v 1.1 2011/01/21 18:45:56 hwoarang Exp $
+
+EAPI=2
+inherit fdo-mime autotools
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.14:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}