summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-10-01 23:37:16 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-10-01 23:37:16 +0000
commit7a086968d760bf973b19faa426589aa7b1166412 (patch)
treed176932c9971477c26acd72d306502fc3814faef /x11-misc/qlipper
parentBump. (diff)
downloadgentoo-2-7a086968d760bf973b19faa426589aa7b1166412.tar.gz
gentoo-2-7a086968d760bf973b19faa426589aa7b1166412.tar.bz2
gentoo-2-7a086968d760bf973b19faa426589aa7b1166412.zip
EAPI=5; add missing deps and fix build.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'x11-misc/qlipper')
-rw-r--r--x11-misc/qlipper/ChangeLog6
-rw-r--r--x11-misc/qlipper/files/qlipper-2.0.2-system-includes.patch18
-rw-r--r--x11-misc/qlipper/qlipper-2.0.2.ebuild28
3 files changed, 43 insertions, 9 deletions
diff --git a/x11-misc/qlipper/ChangeLog b/x11-misc/qlipper/ChangeLog
index edb4e48ea86a..373a97d9af28 100644
--- a/x11-misc/qlipper/ChangeLog
+++ b/x11-misc/qlipper/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/qlipper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/ChangeLog,v 1.5 2013/10/01 22:05:22 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/ChangeLog,v 1.6 2013/10/01 23:37:16 pesa Exp $
+
+ 01 Oct 2013; Davide Pesavento <pesa@gentoo.org>
+ +files/qlipper-2.0.2-system-includes.patch, qlipper-2.0.2.ebuild:
+ EAPI=5; add missing deps and fix build.
*qlipper-2.0.2 (01 Oct 2013)
diff --git a/x11-misc/qlipper/files/qlipper-2.0.2-system-includes.patch b/x11-misc/qlipper/files/qlipper-2.0.2-system-includes.patch
new file mode 100644
index 000000000000..1f478324e3f7
--- /dev/null
+++ b/x11-misc/qlipper/files/qlipper-2.0.2-system-includes.patch
@@ -0,0 +1,18 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a036f9b..92a471a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -187,9 +187,13 @@ include_directories (
+ )
+ if (NOT QTSINGLEAPPLICATION_FOUND)
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/qtsingleapplication)
++else ()
++ include_directories(${QTSINGLEAPPLICATION_INCLUDE_DIR})
+ endif (NOT QTSINGLEAPPLICATION_FOUND)
+ if (NOT QXT_FOUND)
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/qxt)
++else ()
++ include_directories(${QXT_INCLUDE_PATH})
+ endif (NOT QXT_FOUND)
+
+
diff --git a/x11-misc/qlipper/qlipper-2.0.2.ebuild b/x11-misc/qlipper/qlipper-2.0.2.ebuild
index 03892e8f3b81..149176ac258e 100644
--- a/x11-misc/qlipper/qlipper-2.0.2.ebuild
+++ b/x11-misc/qlipper/qlipper-2.0.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/qlipper-2.0.2.ebuild,v 1.1 2013/10/01 22:05:22 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/qlipper/qlipper-2.0.2.ebuild,v 1.2 2013/10/01 23:37:16 pesa Exp $
+
+EAPI=5
-EAPI=4
PLOCALES="cs sr"
-inherit l10n cmake-utils
+
+inherit cmake-utils l10n
DESCRIPTION="Lightweight and cross-platform clipboard history applet"
HOMEPAGE="http://code.google.com/p/qlipper/"
@@ -12,20 +14,30 @@ SRC_URI="http://qlipper.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
IUSE=""
-DEPEND="dev-qt/qtgui:4"
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication
+ x11-libs/libqxt
+"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-system-includes.patch"
+)
+
src_prepare() {
- l10n_for_each_disabled_locale_do rm_loc
+ cmake-utils_src_prepare
+ l10n_for_each_disabled_locale_do rm_ts
}
src_configure() {
cmake-utils_src_configure INSTALL_PREFIX="${EPREFIX}"/usr
}
-rm_loc() {
- rm ts/${PN}.${1}.*
+rm_ts() {
+ rm -f "${S}"/ts/${PN}.${1}.ts
}