summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-09 14:43:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-09 14:43:26 +0000
commitca37866f4564e6b0ad9244e365e9126bd181af0d (patch)
treea54e08a0a385e7db8d04131798f1f6eb32e6bef6 /x11-misc/rednotebook
parentBump, moves utils to /usr/bin/sbin and adds revdep-pax (diff)
downloadgentoo-2-ca37866f4564e6b0ad9244e365e9126bd181af0d.tar.gz
gentoo-2-ca37866f4564e6b0ad9244e365e9126bd181af0d.tar.bz2
gentoo-2-ca37866f4564e6b0ad9244e365e9126bd181af0d.zip
Version bump. Webkit is not optional anymore
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/ChangeLog8
-rw-r--r--x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch17
-rw-r--r--x11-misc/rednotebook/rednotebook-1.2.0.ebuild32
3 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index b6449f9b653d..3310917beb6d 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.49 2011/08/11 11:11:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.50 2011/10/09 14:43:26 hwoarang Exp $
+
+*rednotebook-1.2.0 (09 Oct 2011)
+
+ 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> +rednotebook-1.2.0.ebuild,
+ +files/rednotebook-1.2.0-disable-spell.patch:
+ Version bump. Webkit is not optional anymore
*rednotebook-1.1.8 (11 Aug 2011)
diff --git a/x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch b/x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch
new file mode 100644
index 000000000000..ac4261b99018
--- /dev/null
+++ b/x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch
@@ -0,0 +1,17 @@
+Index: rednotebook-1.2.0/rednotebook/gui/editor.py
+===================================================================
+--- rednotebook-1.2.0.orig/rednotebook/gui/editor.py
++++ rednotebook-1.2.0/rednotebook/gui/editor.py
+@@ -25,11 +25,7 @@ import gtk
+ import gobject
+ import pango
+
+-# try to import gtkspell
+-try:
+- import gtkspell
+-except ImportError:
+- gtkspell = None
++gtkspell = None
+
+ from rednotebook.gui import t2t_highlight
+ from rednotebook import undo
diff --git a/x11-misc/rednotebook/rednotebook-1.2.0.ebuild b/x11-misc/rednotebook/rednotebook-1.2.0.ebuild
new file mode 100644
index 000000000000..23ddbaaefee4
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.2.0.ebuild,v 1.1 2011/10/09 14:43:26 hwoarang Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libyaml spell"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ dev-python/pywebkitgtk
+ spell? ( dev-python/gtkspell-python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${P}-disable-spell.patch"
+ distutils_src_prepare
+}