summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2014-07-04 20:39:57 +0000
committerMatti Bickel <mabi@gentoo.org>2014-07-04 20:39:57 +0000
commit172f35f1f61646d18520cb1551a938395a3e6d76 (patch)
tree95f5f0cc4fbb7cbf3b9379d65e4a61b619455b36 /x11-misc/shutterbug
parentRemove old (diff)
downloadgentoo-2-172f35f1f61646d18520cb1551a938395a3e6d76.tar.gz
gentoo-2-172f35f1f61646d18520cb1551a938395a3e6d76.tar.bz2
gentoo-2-172f35f1f61646d18520cb1551a938395a3e6d76.zip
need libICE and libSM for proper linking (fixes #515310)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'x11-misc/shutterbug')
-rw-r--r--x11-misc/shutterbug/ChangeLog7
-rw-r--r--x11-misc/shutterbug/shutterbug-1.7.47.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/x11-misc/shutterbug/ChangeLog b/x11-misc/shutterbug/ChangeLog
index a5a60fbb9b69..3a39820d9015 100644
--- a/x11-misc/shutterbug/ChangeLog
+++ b/x11-misc/shutterbug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/shutterbug
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutterbug/ChangeLog,v 1.36 2014/01/10 18:28:48 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutterbug/ChangeLog,v 1.37 2014/07/04 20:39:57 mabi Exp $
+
+*shutterbug-1.7.47 (04 Jul 2014)
+
+ 04 Jul 2014; Matti Bickel <mabi@gentoo.org> +shutterbug-1.7.47.ebuild:
+ need libICE and libSM for proper linking (fixes #515310)
*shutterbug-1.7.45 (10 Jan 2014)
diff --git a/x11-misc/shutterbug/shutterbug-1.7.47.ebuild b/x11-misc/shutterbug/shutterbug-1.7.47.ebuild
new file mode 100644
index 000000000000..ce5d9a6799a4
--- /dev/null
+++ b/x11-misc/shutterbug/shutterbug-1.7.47.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutterbug/shutterbug-1.7.47.ebuild,v 1.1 2014/07/04 20:39:57 mabi Exp $
+
+EAPI="5"
+
+inherit fox
+
+DESCRIPTION="Screenshot utility based on the FOX Toolkit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+jpeg +png +tiff"
+
+DEPEND="
+ x11-libs/fox:1.7
+ x11-libs/libICE
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng:0 )
+ tiff? ( media-libs/tiff:0 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ FOXCONF="$(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff)" fox_src_configure
+}