summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-07 06:51:08 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-07 06:51:08 +0000
commit6e316caa0141c4a838503235fd8aa360ab1a427b (patch)
tree0924936ebdf4bff157ca65207dee929ce50e7454 /x11-misc/sisctrl
parentonly spit out cvs info when emerging a cvs version (diff)
downloadgentoo-2-6e316caa0141c4a838503235fd8aa360ab1a427b.tar.gz
gentoo-2-6e316caa0141c4a838503235fd8aa360ab1a427b.tar.bz2
gentoo-2-6e316caa0141c4a838503235fd8aa360ab1a427b.zip
Cleanup ebuild and fix building when xv is disabled.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-misc/sisctrl')
-rw-r--r--x11-misc/sisctrl/ChangeLog8
-rw-r--r--x11-misc/sisctrl/files/sisctrl-0.0.20050618-no-xv.patch12
-rw-r--r--x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild21
3 files changed, 29 insertions, 12 deletions
diff --git a/x11-misc/sisctrl/ChangeLog b/x11-misc/sisctrl/ChangeLog
index 07d8d0d72511..4614df9190c3 100644
--- a/x11-misc/sisctrl/ChangeLog
+++ b/x11-misc/sisctrl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/sisctrl
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sisctrl/ChangeLog,v 1.10 2005/09/15 20:55:31 metalgod Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sisctrl/ChangeLog,v 1.11 2006/01/07 06:51:08 vapier Exp $
+
+ 07 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/sisctrl-0.0.20050618-no-xv.patch, sisctrl-0.0.20050618.ebuild:
+ Cleanup ebuild and fix building when xv is disabled.
15 Sep 2005; Luis Medinas <metalgod@gentoo.org>
sisctrl-0.0.20050618.ebuild:
diff --git a/x11-misc/sisctrl/files/sisctrl-0.0.20050618-no-xv.patch b/x11-misc/sisctrl/files/sisctrl-0.0.20050618-no-xv.patch
new file mode 100644
index 000000000000..4511225600f0
--- /dev/null
+++ b/x11-misc/sisctrl/files/sisctrl-0.0.20050618-no-xv.patch
@@ -0,0 +1,12 @@
+--- src/sisctrl.c.orig 2006-01-07 01:44:13.000000000 -0500
++++ src/sisctrl.c 2006-01-07 01:44:29.000000000 -0500
+@@ -4067,7 +4067,9 @@
+ ( (!(sc.sdflags & SiS_SD_SUPPORT2OVL)) || (sc.sd2flags & SiS_SD2_SUPPORT760OO) ) ) ?
+ 1 : 0;
+
++#ifdef USEXV
+ gl.noxvdemo = (sc.noxvdemo) ? 1 : 0;
++#endif
+
+ #ifdef USE_STRAY
+ gl.dontusesystemtray = sc.dontusesystemtray;
diff --git a/x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild b/x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild
index 7677ec05594c..7033d4b638ba 100644
--- a/x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild
+++ b/x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild,v 1.2 2005/09/15 20:55:31 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sisctrl/sisctrl-0.0.20050618.ebuild,v 1.3 2006/01/07 06:51:08 vapier Exp $
-IUSE=""
+inherit eutils
-DESCRIPTION="sisctrl is a tool that allows you to tune SiS drivers from X"
+DESCRIPTION="tool that allows you to tune SiS drivers from X"
HOMEPAGE="http://www.winischhofer.net/linuxsis630.shtml"
SRC_URI="http://www.winischhofer.net/sis/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
RDEPEND="virtual/x11
>=dev-libs/glib-2.0
>=x11-libs/gtk+-2.0"
-
DEPEND="dev-util/pkgconfig
${RDEPEND}"
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-xv.patch
}
src_install() {
- einstall || die "einstall failed"
+ make install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README
}
-