summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-03-14 21:18:10 +0000
committerKevin McCarthy <signals@gentoo.org>2011-03-14 21:18:10 +0000
commit7521c10acb5188fbe6ba73793a46b47e12d80f51 (patch)
tree22791915bba4c0305ca800ec1641a5f453c4fd9d /x11-misc/wbar
parentVersion bump. (diff)
downloadgentoo-2-7521c10acb5188fbe6ba73793a46b47e12d80f51.tar.gz
gentoo-2-7521c10acb5188fbe6ba73793a46b47e12d80f51.tar.bz2
gentoo-2-7521c10acb5188fbe6ba73793a46b47e12d80f51.zip
Fix issue with 2 Main.cc files and respect for CXXFLAGS. Thanks to xarthisius.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/wbar')
-rw-r--r--x11-misc/wbar/ChangeLog7
-rw-r--r--x11-misc/wbar/files/wbar-2.1.1-as-needed.patch30
-rw-r--r--x11-misc/wbar/wbar-2.1.1.ebuild5
3 files changed, 33 insertions, 9 deletions
diff --git a/x11-misc/wbar/ChangeLog b/x11-misc/wbar/ChangeLog
index 31d104a6314c..03a9610943ec 100644
--- a/x11-misc/wbar/ChangeLog
+++ b/x11-misc/wbar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/wbar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.7 2011/03/13 15:12:35 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.8 2011/03/14 21:18:10 signals Exp $
+
+ 14 Mar 2011; Kevin McCarthy <signals@gentoo.org> wbar-2.1.1.ebuild,
+ files/wbar-2.1.1-as-needed.patch:
+ Fix issue with 2 Main.cc files and respect for CXXFLAGS. Thanks to
+ xarthisius.
13 Mar 2011; Kevin McCarthy <signals@gentoo.org> wbar-2.1.1.ebuild,
+files/wbar-2.1.1-as-needed.patch:
diff --git a/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch b/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch
index b0d1fba7f2bf..93fc68a4991c 100644
--- a/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch
+++ b/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch
@@ -1,17 +1,33 @@
-Put LIBS in LDADD instead of LDFLAGS so --as-needed works.
+Fix automake issues with having two Main.cc
+Fix building with --as-needed
-Patch by Kevin McCarthy <signals@gentoo.org>
+https://bugs.gentoo.org/358557
+
+Patch provided by xarthisius@gentoo.org
--- src/Makefile.am
+++ src/Makefile.am
-@@ -41,8 +41,8 @@
+@@ -22,7 +26,7 @@
+ $(top_srcdir)/src/config/Run.cc \
+ $(top_srcdir)/src/config/Functions.cc \
+ $(top_srcdir)/src/config/Functions.h \
+-$(top_srcdir)/src/config/Main.cc \
++$(top_srcdir)/src/config/Main-config.cc \
+ $(UTILS)
+
+ UTILS = \
+@@ -36,9 +40,11 @@
+ $(top_srcdir)/src/utils/OptParser.h \
$(top_srcdir)/src/utils/i18n.h
- wbar_CPPFLAGS = @modules_CFLAGS@ -I$(top_srcdir)/src/utils
+-wbar_CPPFLAGS = @modules_CFLAGS@ -I$(top_srcdir)/src/utils
-wbar_LDFLAGS = @modules_LIBS@
-+wbar_LDADD = @modules_LIBS@
++AM_CPPFLAGS = -I$(top_srcdir)/src/utils
- wbar_config_CPPFLAGS = @gui_modules_CFLAGS@ -I$(top_srcdir)/src/utils
+-wbar_config_CPPFLAGS = @gui_modules_CFLAGS@ -I$(top_srcdir)/src/utils
-wbar_config_LDFLAGS = @gui_modules_LIBS@
++wbar_CXXFLAGS = @modules_CFLAGS@
++wbar_LDADD = @modules_LIBS@
++
++wbar_config_CXXFLAGS = @gui_modules_CFLAGS@
+wbar_config_LDADD = @gui_modules_LIBS@
-
diff --git a/x11-misc/wbar/wbar-2.1.1.ebuild b/x11-misc/wbar/wbar-2.1.1.ebuild
index 16d87efc6e24..dfff9622dc84 100644
--- a/x11-misc/wbar/wbar-2.1.1.ebuild
+++ b/x11-misc/wbar/wbar-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.1.1.ebuild,v 1.2 2011/03/13 15:12:35 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.1.1.ebuild,v 1.3 2011/03/14 21:18:10 signals Exp $
EAPI=4
inherit autotools eutils
@@ -42,7 +42,10 @@ src_prepare() {
sed -i -e '5,8d' \
etc/wbar.cfg.in || die "Removing wbar-config from cfg"
fi
+ sed -i configure.ac -e "/^CPPFLAGS/d" || die #respect flags
eautoreconf
+ # Fix build issue reported by xarthisius
+ mv "${S}"/src/config/Main.cc "${S}"/src/config/Main-config.cc || die
}
src_configure() {