summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-02 06:06:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-02 06:06:36 +0000
commit9ed2a28fcf25db3570b3f8d177a8d215ebb0551b (patch)
treef28afaabac86a4439db8d05ebd7bbb2125b2f791 /x11-misc/wmakerconf
parentUSE dependent nls compilation (diff)
downloadgentoo-2-9ed2a28fcf25db3570b3f8d177a8d215ebb0551b.tar.gz
gentoo-2-9ed2a28fcf25db3570b3f8d177a8d215ebb0551b.tar.bz2
gentoo-2-9ed2a28fcf25db3570b3f8d177a8d215ebb0551b.zip
Fixed sandbox violations and dependency issues
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/ChangeLog10
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r11
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.8.1-r1.ebuild51
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
new file mode 100644
index 000000000000..5b2b727f5a1b
--- /dev/null
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/wmakerconf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.1 2002/04/02 06:06:21 seemant Exp $
+
+*wmakerconf-2.8.1-r1
+
+ 1 Apr 2002; Seemant Kulleen <seemant@gentoo.org> wmakerconf-2.8.1-r1.ebuild :
+
+ Fixed sandbox violations and corrected the dependencies and USE dependent
+ compilations.
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r1 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r1
new file mode 100644
index 000000000000..f3b723c38256
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r1
@@ -0,0 +1 @@
+MD5 03749f08953638ed2a0ab260a407d264 wmakerconf-2.8.1.tar.gz 666175
diff --git a/x11-misc/wmakerconf/wmakerconf-2.8.1-r1.ebuild b/x11-misc/wmakerconf/wmakerconf-2.8.1-r1.ebuild
new file mode 100644
index 000000000000..70bb500bb966
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.8.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Joao Schim <joao@schim.net>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.8.1-r1.ebuild,v 1.1 2002/04/02 06:06:36 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://wmaker.orcon.net.nz/current/${P}.tar.gz"
+HOMEPAGE="http://ulli.on.openave.net/wmakerconf/"
+SLOT="0"
+DEPEND=">=x11-libs/gtk+-1.2
+ x11-wm/WindowMaker
+ x11-libs/libPropList
+ gnome? ( ~gnome-base/gnome-libs-1.4.1.4 )
+ imlib? ( media-libs/imlib )"
+
+
+RDEPEND="nls? ( sys-devel/gettext )
+ perl? ( sys-devel/perl
+ net-misc/wget )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use imlib || myconf="${myconf} --disable-imlibtest"
+
+ use gnome || myconf="${myconf} --without-gnome"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-wmakerdataprefix=/usr/share \
+ --sysconfdir=/etc \
+ ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ GNOMEDIR=${D}/usr/share/gnome/apps/Settings \
+ install || die
+
+ dodoc README MANUAL AUTHORS TODO COPYING ChangeLog
+ dohtml -r .
+}