summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-07-03 09:05:39 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-07-03 09:05:39 +0000
commit2feca99e7cc7db85fed9d8611cd7f250ce6a0035 (patch)
tree9e9e820978c6b450be921b4c527484a736bc3d48 /x11-misc/x2vnc/x2vnc-1.7.2.ebuild
parentBump to latest version and remove old ones. (diff)
downloadgentoo-2-2feca99e7cc7db85fed9d8611cd7f250ce6a0035.tar.gz
gentoo-2-2feca99e7cc7db85fed9d8611cd7f250ce6a0035.tar.bz2
gentoo-2-2feca99e7cc7db85fed9d8611cd7f250ce6a0035.zip
Version bump
(Portage version: 2.1)
Diffstat (limited to 'x11-misc/x2vnc/x2vnc-1.7.2.ebuild')
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2.ebuild
new file mode 100644
index 000000000000..db5cd1768d99
--- /dev/null
+++ b/x11-misc/x2vnc/x2vnc-1.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.7.2.ebuild,v 1.1 2006/07/03 09:05:39 phosphan Exp $
+
+DESCRIPTION="Control a remote computer running VNC from X"
+HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
+SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="tcltk"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXext
+ x11-libs/libXinerama )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+ x11-proto/xineramaproto )
+ virtual/x11 )
+ tcltk? ( dev-tcltk/expect )"
+
+src_install() {
+ dodir /usr/share /usr/bin
+ make DESTDIR=${D} install || die
+ use tcltk && dobin contrib/tkx2vnc
+ dodoc ChangeLog README
+}